Danfoss TLX Pro+ Inverter integration to Home Assistant?

Jeg har lige fået min 8kW til at fungere.
Hvor i landet?
Har du købt ESP32 Lolin og RS485 modul ?

Hi would this be posible for ESPhome?
Also I litle more guide for setting up the Arduino if ESPhome not posible.

jeg bor i nordsjælland hillerød
skal det være ESP32 Lolin har nogle esp8266 og et
RS485 modul

Is it possible to buy the complet package? Print, moduls and with data? Plug and play version? I’m not so clever to manage all that, but would love to have my Danfoss TLX inverter at HA. After Danfoss sold their inverter to SMA the Danfoss app hasn’t worked.

@majland Finally got around to making a PCB and testing it out. However I don’t get any data from the inverter :(. Do I need to set the address to the inverter somewhere?
(From PowerLog, I get Network=8, Subnet=0, Address=144)

Edit: Got it working. Had swapped RX/TX on ESP32 :(.


I’m also searching for a way to get data from our danfoss inverters. Is there a setting to enable the TotalE website? When I try to request http:///TotalE or ProdTday i only get the message “There has been an error. Please try again.”


I’ve not been following this thread - sorry.

But i have updated the code to get all the values in a single request packed in the same json response.

I’ve helped another getting it running and he has the same issues with his inverter not reponding to all the same as above - with some reposnses being 13 long and other 0.

With regard to ESPhome: I’m not familier enough with ESPhome but cant see why not. Drop the web part and implement the sensors more directly and the comlynx part should port easily.

Does not sound like a resonse from the ESP.

If you enter a something not recognized by the boad you will get a respons like

Pararameter not recognized

Method: GET
Arguments: 0

Can you see the main overview directly on the IP address starting with the heading “Danfoss TLX”

The code can not directly compile for the ESP8266 due to differences in libraries related to network (Had a quick look at the D1) But i think it should be powerfull enough.

I’m struggling a bit with the lack of response on specific parameters. Some are always returned as zero. Unfortunately I haven’t got any other software to compare with, so I don’t quite know where the problem is

Yes it is a bit weird. Claus is seing something similar and it is allways the same registers he get garbage responses from. The length of the reply is either 0 or 13 long (ie ignored or possible an error message)

Above someone mentioned that on some registers the following request would cause an error.

When i made the long enums i went trough all the relevant registers for my inverter and i included all that gave meaningfull results. It seems that not all inverters/firmwares return the same.

Would be intesting to read the registers from the last to first to see if that moves the errors or just start with one of those that falls (that is simple to change - Instead of letting the index i start from 0 you could set it to PvA1)

Line 258 static int i = TotalE to static int i = PvA1 and the same in line 295

Or change the code to test all the registers one at a time.

Grid DC can be 0 but PVA1 as well as the production should not.

The registers for the current is 022D", “022E”, “022F”, so just after each other

From the ComLynx Manual :

Claus’s inverter will not output the the values from L3 - He only get 13 instead for 22 characters that can not be interpreted while it i sko for L1 and L2

We also tried reading them in reverse order L3, L2 and then L1 and it was the same that failed. Guess we will have to try to decode the content of those 13 chars in response …

He then wrote the 4.13 firmware back to it again without any changes

He has also access to a spare comm board that he tested and that did not make any difference either.

Just debugged “SunLog” output from the PowerLog Application which also integrates with Danfoss TLX. He doesn’t use any of the troubled registers, so that doesn’t help much.

Which SW versions are your Inverters running? Mine is running:
Inverter: 4.06
Comms: 3.55(5)
Control: 1.47(1)
FSP: 0.52
Display: 0.13

I do have a service pack which I didn’t install. This contains:
Comms: 3.75(1)
Control: 1.56(3)

But I’m not sure I dare updating it :thinking:

Edit: That service pack is the same as v4.13.

1 Like

I’m on 4.13 and Claus is as well.

He has also access to a spare TLX15 so the plan it now to get that connected to AC (since values does not matter anyway since it is a reading error)

Just updated my Lolin to current version. (it is a Lolin 32 Lite)
My TLX has same software as yours Anders. My inverter is: TLX Pro+ 8k, and it has 2 PV inputs
As photo shows most data is readen correct, except Grid current and power per phase.

Not that much of a problem for me, because the 3 phases are always almost identical.

But it would be nice to find a solution anyway.

Ved du om der er noget der har lavet en plug and play pakke man kan købe ?

Har du en tegning over hvordan ESP32 og RS485 skal forbindes, syntes ikke jeg kan finde det nogle steder

The connection is decribed in the header file

And there is a picture of my prototype the issues section of github:

Unfortunately not. It would be nice with a small print with ESP and adaptor board just plugged in. Bonus would be a din rail mount that could be 3d printed …

If somebody draws a print i would buy one myself as I still have the breadboard prototype running “production”

Jeg har en Lolin D32 og RS485 modul
men kan ikke finde udaf at compile filerne
kunne du evt ikke sende lidt info om hvordan man gør eller kan man bruge den file som du har compilet til dig selv ?