Deako custom integration - version key problem

I am using a custom integration to control Deako lights (github) . Since the update to v2024.3 my integration is failing w/ the error “The custom integration ‘deako’ does not have a version key in the manifest file and was blocked from loading”

i checked based on the warnings and the manafest has a version key in it.


  "domain": "deako",
  "name": "Deako Smart Lighting",
  "documentation": "",
  "issue_tracker": "",
  "iot_class": "local_poll",
  "dependencies": [],
  "config_flow": true,
  "codeowners": ["@sebirdman"],
  "requirements": [],
  "version": "0.0.1"

i tried a few things w/o luck:

  1. moving the “version” entry in the manifest, changing it from minor 0.0.1 to major 1.0
  2. the custom code is installed in custom_components/integration_blueprint. Following this version key comment, i tried renaming folder “integration_blueprint” to “deako”.
  3. option #2 but this time fully removed the custom integration and recreated it with the same target IP.

Followed by a HASS restart.

any other suggestions?