Debian - installing hassio problem

hello
i have followed the tutorial to install hassio on a nuc
i am with debian
when i run the line

# curl -sL "https://raw.githubusercontent.com/home-assistant/hassio-installer/master/hassio_install.sh" | bash -s

nothing happens…
it should install but it does not. what can i do?

Like I tried to tell you in discord multiple times remove the # at the start of the command…

i dont use that # in the command

If you don’t do that, don’t post it with that…

See the difference ?

[email protected]:~# # curl -sL "https://raw.githubusercontent.com/home-assistant/hassio-installer/master/hassio_install.sh" | bash -s
[email protected]:~# curl -sL "https://raw.githubusercontent.com/home-assistant/hassio-installer/master/hassio_install.sh" | bash -s
[Info] Install supervisor Docker container

with # returning nothing (that is a comment), without it starting to install

Uploading: 15618329809967758072004354578846.jpg…

Did you install the prerequisites?

Yes i did (((

curl -sL https://raw.githubusercontent.com/home-assistant/hassio-installer/master/hassio_install.sh | bash -s

Use that command as root instead. Yours is wrong. You have an extra “blob” in there.

You’re all over the place here.

You have to use sudo or run as root to use apt.

You need to run the command as root.

It’s telling you to install avahi-daemon which you attempted but didn’t do it with proper permissions, as the error message tells you.

1 Like

can you please guide me? i cannot make it by myself :frowning:

i am doing like this:
terminal

sudo apt-get install avahi-daemon
what i get is: …daemon is already the newest verion 0.6.32-2

but when i use sudu curl -sL … it says:
error - please install avahi first

You need to install the list of prerequisites first as sudo.

If all the prerequisites are actually installed already then you simply su to login to root and run the command. I’m not really sure why you’re having problems but have you made sure it hadn’t installed anything?

If you run sudo docker ps -a it will tell you if you have ha running or not.


HaHave this

i am restarting the instructions and after sudo -i
the add-apt-repository universe gives me error universe invalid

What repository are you adding?!

trying this

$ sudo -i
# apt-get install software-properties-common
# add-apt-repository universe
# apt-get update
# apt-get install -y apparmor-utils apt-transport-https avahi-daemon ca-certificates curl dbus jq network-manager socat
# curl -fsSL get.docker.com | sh

You don’t need to reinstall docker. You have docker running…

the problem i am facing is:

add-apt-repository universe

gives error
curl -sL “https://raw.githubusercontent.com/home-assistant/hassio-build/master/install/hassio_install” | bash -s
does return only the prompt and does nothing :confused: