deCONZ Addon


I built a plugin for deCONZ (software for the conbee/raspbee zigbee adapters).

Feedback welcome!

Open issues:

  • Firmware updates untested
  • OTAU untested (but you can copy otau files in /config)
  • builds locally, takes a while to install
  • raspbee currently untested

I noticed afterwards that there already is another addon available, maybe we can clean one of them up to include it in hassio-addons.


Great work! There are known limitations with deconz inside of a docker. Check with @marthocoo about ways to go about this. He is communicating with Dresden.



I recently switched from the other one to yours, and at first glance yours seems to be more “proper”.

I did have some issues logging into phoscon html5 app using the link provided in the addon page.
It may be because I am using duckdns and ssl so the link does not point to the correct place.

It also says httpadress…/[HOST]:8234 instead of the actual ip of the host. But replacing the duckdns adress and the HOST bit to my Pi IP does let me log into Phoscon. If trying to log into http//IP.Adress:8234 it won’t find the Conbee, so I need to do http://Ip.Adress:8234/pwa/login.hmtl#/Ip.Adress:8234 to see it.

According to the manufacturer that is probably due to not using the stock port.

A question however: A big difference I noticed is that yours seems to save its settings and database in the Deconz/share folder in config. Whereas the other one saved it god knows where, probably the os root. This means yours will be safer to update etc, right?

1 Like

Unfortunately the replacement mechanism is not flexible enough to replace the host variable twice in the link. It works better in the deCONZ 2.05 beta, where you can always use http://Ip.Adress:8234/pwa/

You can move the config backup more easily this way. But it shouldn’t hurt to do backups in phoscon.

1 Like

They fixed this in the latest deconz release, 2.05.08 or .07 I think

Great! @neffs I suppose you will update the addon in due time with new releases?

I just updated to 2.05.10 beta and added gui access

Hey @neffs - I didn’t see your work before creating my own deCONZ Add-on: Interested in collaborating? Mine works with Conbee and another user confirmed it works with RaspBee (in fact the creator of the other other deCONZ add-on). I’ll take a look at your code to see if there’s any major differences between ours but in a nutshell mine:

  • Is based on a Docker Hub image so it doesn’t have to build locally;
  • Runs in host networking mode so that uPNP discovery for PWA works properly;
  • Allows changing the webui and websockets ports;
  • Supports Conbee and RaspBee.

Sure, I just implemented it because I needed it. We don’t need to do the same work twice.

I think these are the main differences of my addon:

  • optional access to the QT gui with Xpra (currently with fixed port and without authentication)
  • deconz config is exposed to config dir, including access to otau folder
  • conbee udev hack is optional (not sure if it would impact other usb-to-serial devices)

your addon on the has the wiringpi packages, does not need to be built locally and seems to have more options.

I tried to build the run script in such a way that it would be easy to add more options for command line parameters as they are added.

I need to take a look at how I’m persisting addon data - placing it in the config dir is a good idea. The Hassio documentation says that /data is for persistent data but actually I’m not sure where that ends up on the host.

As far as I can tell adding the udev info shouldn’t have any effect on another USB device since it’s only “hacked” inside the deconz addon container to fool deconz into finding the Conbee. Outside the container no other USB device nor other addon will be aware of it so I can’t see how it would have an impact.

What does access to the QT GUI do for us?

not sure how deCONZ would handle another matching usb-to-serial device. maybe it would connect to it and prevent other software from connecting. I did not run into any issues myself, just wanted to be safe.

the GUI shows the zigbee mesh, can update the firmware of zigbee devices and configure almost everything you can think of.
I just used it because I got a new aqara zigbee button which does not show up in PWA. But now at least I know that it successfully joined the network because it shows up in the mesh.

1 Like


I’ve been using both of your Deconz add-ons. Switched to @marthocoos add-on to be able to test my Xiaomi Wireless Remote (AQ3), moments before @neffs was raised to 2.05.10 :slight_smile:

Anyways, I’m having trouble adding my Xiaomi Wireless Remotes (AQ3) now on release .10 and .11. Are you able to join your AQ3 remotes successfuly?

I was able to join all three of my remotes on 2.04.99 but not any longer. Joining on my computer works fin (which is at 2.04.99) but not on my Rasberry with, now running 2.05.11.

I own a conbee usb version, can you explain to me what I need to do to get it working from step 1, do I need to do som editing in any file so Hass can find my stick if so what? And what do I need to do after that?

I’m also in need of help getting the deconz addon up and running. I’ve tried both but when trying to configure in homeassistant (after pressning the “I have unlocked gateway” button) I get a 500 internal server error in the tab. Running hassio rp3 conbee usb. Have I missed any obvious steps?

I see this issue beeing discussed in another thread

It’s a bug in the current release. It is fixed in the new beta. If you want to stay on stable you can enable debug for the configuration per component documentation and then try to setup, the component. You would then get the api key in the logs so you can manually set up the component

I am using on a RPi3 with a raspbee premium and the deconz addon with several zigbee devices and I am wondering how to get acces to the zigbee mesh gui?

Right now you need to run it on a machine with a desktop. There have been talks about supporting x-forwarding from the container, but I don’t think theres been any work in that field yet.

Thanks. I am able to use it on Windows desktop but not sure how to connect and/or view the zigbee mesh because the raspbee is connected to the RPi3. Is it necessary to connect the raspbee to the same desktop or is it possible to import some sort of config files exported from the deconz addon?

You need the desktop to be on the same machine as the raspbee.