deCONZ entities unavailable after reboot

Running 0.104.2 and my Deconz integration has stopped working. No changes to my config in the last few days so nothing to go back to.

All entities are unavailable although the integration still appears. Weirdly though the Deconz integration is coming up as needing to be configured again as it’s seems to have been discovered again.

Going into the actual Deconz plugin allows access to all entities so they haven’t been lost.

Any clues?

1 Like

yep it was explained in the release notes
just remove the current integration wait a minute or two and configure the new

Thanks for the reply. I had done that yesterday, but overnight HA restarted and it was lost again.

Trying again now.

Same problem here, after a restore to 0.103.6 HA connected to deconz just fine.

I have posted it to the deconz official thread yesterday:

But I have found no workaround than downgarde to 0.103.6 yet… :worried:

It can’t be that way that everytime you restart Hassio you need to remove and add the deCONZ integration? Super annoying.

I have a similar problem. Running 0.104.3 and phoscon gateway. My entities randomly become unavailable during a couple of seconds:
Tried several things without result. Went back to 0.103.6. and the problem disappeared.

@pitikay, I am new to home assistant. Heard about docker, but don’t know what it is. I just installed HA on a pi.

@David_Hendrikx @pitikay I have the same issue. Was anyone able to get rid of the from time to time unavailability issue?

1.5.2 works :slight_smile:

I’m having this issue too, but I have HA running in a proxmox VM with usb passthrough. I don’t have an issue if a simply restart HA, but when I reboot the entire VM I lose the deconz stick. A simple unplug and replug does the trick, but it’s annoying. Not sure if this is an HA issue or proxmox issue?

1 Like

Similar issue that I’m having as well. Restarting my entire Docker stack breaks the deCONZ integration until I restart only HA.

Initially the problem was much worse before I used host networking for the deCONZ Docker container, as the IP would constantly change and the HA integration would not update, forcing me to re-add the integration every time I restarted.

I upgraded deConz to 5.2 this evening under 0.105.5 and lost everything. Forgot to take a Zigbee backup first and was sweating bricks there for a while. :open_mouth: Seems HA lost access to /dev/serial/by-id/usb-dresden_elektronik_ingenieurtechnik_GmbH_ConBee_II_DE1963863-if00 but after removing the Conbee and plugging it in to another USB port (Intel NUC/Proxmox), it came back. Would not work with /dev/ttyACM0 either. First time I’ve seen this after moving to a by-id path in my z-wave and zigbee config.

Used to have issues all the time with device restarts when only using /dev/ttyACM0 or /dev/ttyACM1 as these paths are randomly assigned on system reboot so whichever stick starts first, it gets allocated the first port sometimes rendering both sticks unavailable.

I always use udev rules for this, see here

I’m running Hassio so that options out for me.

Same here, I allways have to restart my HA VM after a NUC/Proxmox reboot because all deconz entities in HA are unavailable, while in the deconz addon UI everything seems okay…
At least the HA VM restart is a workaround, next time it happens I will try the unplug/replug USB stick method.

1 Like

Same issue here, done it for ages across multiple builds of HA. If the machine is rebooted all is unavailable until I reboot just the ha instance.


Im just getting a few devices missing since the last update…But it generally seems a lot less responsive…My Magic Cube has stopped working completely and no matter what I do will not respond to any inputs even though it says its connected…Also some of my osram dimmable bulbs just drop off the system…Never had any issues before with updates

same issue, need reboot VM after nuc starts

Same issue here, also on a nuc.

Strange thing I lost power 3 days ago and no issue, today I updated to latest versions, rebooted. entities unavailable…

Went to services, deconz.device_refresh some devices came back, but not all… Removed integration, added it again and everyting is back

Very strange, after last Update all Powerplugs and Lights are unavailable (Innr, Osram, Hue) in Home Assistant but shown in deconz. BUT the powerconsumption informations of the Innr Plugs are still active and changing.

The remotes and sensorts added vie deconz are still active

Removing and adding Deconz again doesn´t fixed it.