Deconz error after upgrading to 0.78

That is where you get the logs.

It would indeed seem that the component doesn’t cover this situation.

I will look into fixing this. I can’t promise when, within a release or two.

Interesting observation - it doesn’t work indeed if I try to activate the log level. It works as long as I don’t use logger with homeassistant.components.deconz. If I try to log deconz I get the same error as Csiza “couldn’t load data from deconz”.
As soon as I uncomment the logger deconz works as intended.
Just fyi.

For me it only work until version 0.77.3.
On 78.0, 78.1, 78.3 same issue. I am back on 77.3 now works fine everything and waiting for your fix Robben. Many thanks in advance.

Just adding myself to the list of users encountering this timeout issue when HA initially starts. Have been struggling the last day as I’ve migrated to a new SD card and thought there was something I’d screwed up, but appears it’s not my problem after all.

You might consider bringing up HA after deconz. In the HA service file (usually /etc/systemd/system/home-assistant.service) put deconz-gui.service in the [Unit] After= section.

I tried all different kind of order but the result is the same.

I still need logs

Will send Tonight…

1 Like

Just to chime in, I have the same issue. Cannot provide the log as of yet either.

The only thing I see in the logs is
2018-09-25 16:29:49 ERROR (MainThread) [pydeconz.utils] Timeout getting deCONZ data from
2018-09-25 16:29:49 ERROR (MainThread) [pydeconz] Couldn’t load data from deCONZ

I can access Phoscon fine from any device but no lights or sensors are picked up, what else do you need I couldnt see anything else relevant in the logs?

and logs are now full of this:

RuntimeError: File descriptor 45 is used by transport <ReadUnixTransport closed=False reading=True 0x7f8aa6147048>
2018-09-25 16:40:05 ERROR (MainThread) [homeassistant.core] Error doing job: Exception in callback <bound method SendfileStreamWriter._sendfile_cb of <aiohttp.web_fileresponse.SendfileStreamWriter object at 0x7f8aa4b4bd68>>
Traceback (most recent call last):
File “uvloop/cbhandles.pyx”, line 66, in uvloop.loop.Handle._run
File “/usr/local/lib/python3.6/site-packages/aiohttp/”, line 37, in _sendfile_cb
File “uvloop/loop.pyx”, line 2272, in uvloop.loop.Loop.remove_writer
File “uvloop/loop.pyx”, line 787, in uvloop.loop.Loop._remove_writer
File “uvloop/loop.pyx”, line 692, in uvloop.loop.Loop._ensure_fd_no_transport

are you fix that?
Have the same issue.

So, Last night I wanted to generate the debug log, but something went wrong. Then after a couple of hours of troubleshooting I ended up on version 0.79.0b1 and everything is working just fine. How am I ended up with a beta version don’t ask. It is still showing there is an update to 78.3. I am just hoping now that a not beta 79 version will also work.

Side note, when you install version 79 (beta too) check integration menu. There are some cool new features there… :wink:


Couldn't load data from deCONZ hints at a network issue. It fails at the earliest point of the components setup so it can’t talk with deconz.

The other logs show some core issue. Not enough to go on for any deconz issue.

Does everything else work for you?

I suggest upgrading to latest 0.78 and start disabling components.

0.79.0b1 works for me as well, very weird.

Yes everything else works fine, pi-hole sensor says the same thing but then works eventually (after a few minutes)

0.79.0b2 now all working

1 Like

Having new issues on new 79.1, 79.2 versions. Moving this to HA issue tracker.

Sounds good. That is a better tool

For reference: