Deconz for


Tried this after my post - doesn’t change anything.


Can you change the actual routing through the mesh? I thought that was something that the deconz platform did itself over time?


I’m in the same situation, I think I need the firmware upgrade to get the support for some new sensors.

My challenge here is that last time I did the upgrade, I just put the Conbee in to a PC and upgraded the firmware, now I’m getting a much older firmware stated in Phoscon running it from the PC than what I’m seeing running it from

So I looked in to the SSH firmware upgrade instead, I’ve got two challenges with that. I’m not getting the file name stated in the log. I only got two lines there:

13:40:47:063 GW firmware version: 0x261f0500
13:40:47:063 GW firmware version shall be updated to: 0x262f0500

Nothing about the file name, then I thought that I would “assume” that the file name is as described in the instructions since it seems to be the firmware version with a path. But then I got stuck at not being able to run the docker command from SSH.

What I’m getting is "Error: unknown command “docker” for “hassio-cli”.

I’m supposing I’m doing something wrong, but I’m not able to google my way through this one.


I had the same problem with Windows, but I found a newer version of deconz for Windows on their github page and after installing that I could update to the newest firmware.


Cool, I’ll give that I try. Again, never assume, I would assume that Deconz for windows would tell me if there was a newer version. :slight_smile:


I would also have thought that deconz would update itself or that it shouldn’t matter for the conbee sticks firmware, but it did in my case :grinning:


Solved it for me for now. Got 0x262f0500 update.

But it would be easier if I got to know why I can’t run docker command on, if I get the instructions right, it should be possible.


It didn’t in my case. I manually changed it and now it works fine!


Did you get the Phoscon app version updated as well?

I managed to get the firmware upgraded, but the Phoscon app is still the same version as before and I now got a button in Phoscon that says that I should update the app itself. But that doesen’t work from Hassio and using the conbee on a laptop it’s the newer verson of Phoscon. So I suspect that the app comes from deconz rather than directly from the usb-stick.

I suppose we have to wait for another upgrade of deconz add-in that will bring the new version of Phoscon.


Where do you get the button in Phoscon? I haven’t seen any button prompting me to update and I don’t see it in the log either.


Latest version is 2.05.52


It was in the Phoscon app, where my version was stated as .49 and there was a button for upgrading Phsocon (not firmware) but the button was on the same place as the upgrade firmware button shows up.

Now I’ve upgraded the add-on and everything is good.

Advise for anyone fiddling around with this is to not uninstall and then install deconz add-on again, then you will lose all your connected devices.


Okay mine did show the newest version there.


Just a heads up to everyone: my docker image has been updated to version 2.05.55 and this release includes support for VNC contributed by @neffs (meaning, you can connect to the container via VNC and view your ZigBee mesh!). The addon now has this capability for version 2.05.55 onward as well. Thanks @neffs!


How long does it usually take for the addon to show the update as available?


In the menu, go to addon store tab, then hit the refresh icon in the top right corner (looks like a circle-arrow). Go back to the Dashboard and voila update available.


For me vnc doesn’t work, enabled it though
Also phoscon webinterface is now seems hardcoded to port 80 instead of 8080, do you need to reauthorize the conbee Stick again… Opened an issue tracker for it


So after upgrade, Phoscon app seems to be on port 80 now. No entitites show up in home assistant anymore. Seems to be no integration anymore between deconz and home assistant. How to solve this? How can i downgrade to .54?


Removing and readding integration for deconz solved it!


Indeed , had to do this also for now
Be careful if you have port 80 open on your router for let’s encrypt certificate, :wink: