Deconz for Hass.io


#267

So, except phsocon being on port 80 now everything is back to normal after removing and readding deconz integration.

However, in addon config I set

“active”: true

,
and changed password

“password”: “MyPassword”

However I am getting connection refused when trying to connect with real vnc. Anyone got it working with the addon in hassio?


#268

no, vnc not working here, also changed to true


#269

Re-adding the integration solved the unavailable sensors, thanks for the tip.
The vnc connection is refused by the host for me as well, I don’t see anything in the addon log.
Port 80 is now hardcoded and will cause problems to the SSL cert renewal.


#270

yes, already a fix in progress, so we can go back to 8080 or something else
probably with next update , we need to authenticate the conbee again, like we had to do now


#271

#272

indeed, can we maybe change this manually in some file? or do we need to wait for the update fix?


#273

I’ve pushed the update fix to Docker Hub and to my Add-on repo. Version 2.05.55.1 should now be available to download and should fix the problems Hass.io users have been experiencing.


#274

Thnx, but

Port is still not fixed in this build, seems it’s stuck at 80 regardless config setting


#275

As reported in this issue, the reason the 8080 port config is not being respected under Hass.io is it appears some variables are missing the HASSIO_ prefix:
https://github.com/marthoc/docker-deconz/blob/master/amd64-hassio-addon/run.sh#L24-L25

This was all changed in this PR https://github.com/marthoc/docker-deconz/pull/88


#276

Indeed, can we manually change but in our json file? Or ?


#277

I’m not sure offhand @pergola.fabio.

@marthocoo I opened this PR with what appears to be the proper fix: https://github.com/marthoc/docker-deconz/pull/93


#278

Hi there,

I am currently unable to load the phoscon web-ui (no connection). Perhaps i forgot a step in the setup…

-Hardware: raspberry pi3 + raspbee shield
-Running Hassio and installed the deconz plugin from https://github.com/marthoc/hassio-addons repository
-added the following lines at the end of my config.txt via sdcard reader:
enable_uart=1
dtoverlay=pi3-disable-bt
(with an additional blank line at the end)

  • did a full reboot
  • my System hardware lists following devices
    serial:
    /dev/ttyAMA0
    /dev/ttyS0
    input:
    disk:
  • went to the deconz plugin and changed the configuration for the device to:
    “deconz_device”: “/dev/ttyAMA0”,
  • started the plugin which now shows a green circle on the upper right corner
  • rebooted the raspberry

However when i press on the “open web ui” button the phoscon webui won’t load.
Am i missing any steps? I also tried to change the device to “/dev/ttyS0” without any luck.

The Log on the plugin page shows me several entries with a firmware update. Is this an indication that the configuration is correct?

22:48:19:570 discovery server date: Wed, 16 Jan 2019 21:48:19 GMT
22:48:19:570 local time seems to be ok
22:49:18:294 Current channel 15
22:49:42:750 dev /dev/ttyAMA0
22:49:42:750 GW firmware version: 0x26050500
22:49:42:750 GW firmware version shall be updated to: 0x262f0500
22:50:18:286 Current channel 15
22:51:18:294 Current channel 15
22:51:53:781 dev /dev/ttyAMA0
22:51:53:781 GW firmware version: 0x26050500
22:51:53:782 GW firmware version shall be updated to: 0x262f0500
22:52:18:285 Current channel 15
22:53:18:294 Current channel 15
22:54:04:794 dev /dev/ttyAMA0
22:54:04:795 GW firmware version: 0x26050500
22:54:04:795 GW firmware version shall be updated to: 0x262f0500
22:54:18:291 Current channel 15
22:55:18:294 Current channel 15
22:56:15:629 dev /dev/ttyAMA0
22:56:15:630 GW firmware version: 0x26050500
22:56:15:630 GW firmware version shall be updated to: 0x262f0500
22:56:18:286 Current channel 15
22:57:18:293 Current channel 15
22:58:18:285 Current channel 15
22:58:19:634 Announced to internet
22:58:19:634 discovery server date: Wed, 16 Jan 2019 21:58:19 GMT
22:58:19:634 local time seems to be ok
22:58:25:792 dev /dev/ttyAMA0
22:58:25:793 GW firmware version: 0x26050500
22:58:25:793 GW firmware version shall be updated to: 0x262f0500
22:59:18:284 Current channel 15
23:00:18:292 Current channel 15
23:00:36:650 dev /dev/ttyAMA0
23:00:36:650 GW firmware version: 0x26050500
23:00:36:650 GW firmware version shall be updated to: 0x262f0500


#279

Yes, phoscon still runs on port 80


#280

If you want to avoid resetting deconz integration, I’ve just checked that port can be changed (to 80) in .storage/core.config_entries file in the config directory. HA needs to be restarted after this change.


#281

Good tip, we will can do this when new bugfix comes out to change 80 to 8080 :wink:


#282

Update won’t show for me. Tried refreshing repositories multiple times.
Will I break anything if I remove the add-on and re-add (then restore Phoscon backup) ?


#283

nope, have dont it also
remove integration
access phoscon port 80
authenticate conbee again
add integration, and all devices are back


#284

ahh great thank you for the reply. Indeed it’s running on port 80. I tried to add a philips hue motion sensor which succeeded. However it doesnt show any values for the temperature and light sensor. The motion detection only triggered once after adding the sensor and it seems like the sensor is not updating at all. Tried restarting and adding the sensor anew.


#285

you need to reauthenticate the conbee stick


#286

You can also change the port of the component, then you won’t need to reauthenticate. Go into .storage/.core.config_entries and change deconz port