Deconz for Hass.io


#327

You can do this via automations in HA (different buttons emit different signals on press, hold etc, check out the documentation here), but here’s how I did it in the Phoscon UI:

When you have a light group selected, click the “link switch” button, select a key, and what you want to assign it to. Select a different group, link switch, select another key, and a command. Using this pattern I can now control 4 different groups of lights (using the option to long press for dimming and regular press for on/off). Middle button (power) switches all lights on/off.

I realize when I re-read your question that maybe want to be able to control multiple aspects of several groups simultaneously – I think you can do stuff with AppDaemon if you want even more control.


#329

Hi all,
Lately I’ve experienced several times that my ikea bulbs (5 bulbs, three different types) become unavailable in Deconz out of the blue - no error messages anywhere, Xiaomi battery devices are still working and restarting Deconz (add-on version, updated to newest version, FW also newest version), Hass.io or rebooting the entire system doesn’t solve it - need to re-include the bulbs (which are then recognized as the same devices as before).
Any ideas what’s causing this behavior and how to solve it?


#330

I have just upgraded from 2.05.54 to 2.05.57 without issue (having previousl reverted back at one point to avoid the issues I was facing on some of the intermediate versions - I guess these are the same issues people talked about above).

I am running on Raspberry Pi 3b+ with a conbee. Can anyone tell me the easiest way to update the firmware for conbee? I don’t have easy access to swindows or Mac PC.

James


#331

If you are running hassio.


#332

Thanks. I haven’t set up SSH Access but managed to follow the same process by plugging in the Pi to an HDMI to my TV and a keyboard.


#333

Hm, actually although I saw success messages my Deconz log still indicates that the firmware has not updated (still on 0x261f0500)


#334

On second attempt, the log now reports firmware as up to date.


#335

Hi all,

I am running deCONZ on Hass.io on a RPi 3+ with a Raspbee and got everything working with some Trådfri sensors and lights through the Phoscon web-UI. I got a lot of helps from this forum, so thank you!

Now for my question: Can I run the deCONZ GUI software on my windows computer or somewhere else to control the full network?
I tried just installing the software on my computer, but it does not connect to the Raspbee.


#336

For the standalone container there is already support for vnc to use the desktop application and there is work to get that into the addon as well


#337

Okay, I’m currently using the add-on, so I will look out for vnc support through that.

Thank you


#338

I can’t seem to update to the latest Rasbee firmware…

I updated the add-on this morning to 2.05.58 successfully, all my lights and sensors are fine, the Phoscon GW is telling me 0x0262f0500 is available to update to (currently running 0x26240500), when I login to the HASSos portion and run docker logs blah, I get the following:

10:23:41:980 dev /dev/ttyAMA0
10:23:41:980 GW firmware version: 0x26240500
10:23:41:980 GW firmware version shall be updated to: 0x262f0500

However, after stopping deconz, when I run:

docker run -it --rm --entrypoint "/firmware-update.sh" --privileged --cap-add=ALL -v /dev:/dev -v /lib/modules:/lib/modules -v /sys:/sys marthoc/deconz

I only get the following:
deCONZ_Rpi_0x261f0500.bin.GCF
deCONZ_Rpi_0x26230500.bin.GCF
deCONZ_Rpi_0x26240500.bin.GCF

Giving it the 263f0500.bin.GCF fails with an update not found.

This procedure has always worked for me in the past, not sure what I’m missing…

Cheers.


#339

Do a docker pull marthoc/deconz then run the script command again:
docker run -it --rm --entrypoint "/firmware-update.sh" --privileged --cap-add=ALL -v /dev:/dev -v /lib/modules:/lib/modules -v /sys:/sys marthoc/deconz


#340

Argh, so simple.

Thanks. much appreciated!


#341

Hey there,
got the same issue right here:

Seems like the raspbee isn’t connected properly.

hassio hw info:

core-ssh:~# hassio hw info
{
“result”: “ok”,
“data”: {
"serial": [
"/dev/ttyAMA0"
],
“input”: [],
“disk”: [],
“gpio”: [
“gpiochip128”,
“gpiochip100”,
“gpiochip0”
],
“audio”: {
“0”: {
“name”: “bcm2835_alsa - bcm2835 ALSA”,
“type”: “ALSA”,
“devices”: [
{
“chan_id”: “0”,
“chan_type”: “digital audio playback”
},
{
“chan_id”: “1”,
“chan_type”: “digital audio playback”
}
]
}
}
}
}

Seems like I have to add those lines to the config.txt, but im not sure how:

enable_uart=1
dtoverlay=pi3-disable-bt

Running HassOS. I’ve plugged in the SD-card into a Mac / Windows, none of them booted up the card :confused:

Someone got a clue how to do this?
Many thanks in advance!


#342

If you insert the SDCard in your PC you should see one drive appearing, and some PC’s report one formatting issue (ignore that).

On the drive added there should be a config.txt in the boot directory.


#343

Hey gjong,

thanks for your quick reply.

On the PC (windows) it says that I have to format the SD card as there was no known file system detected. So I get no access on it, even on the boot directory.

On Mac the drive won’t even get mounted.

Maybe the card is broken? But if so, why hassio still runs like a charm? :open_mouth:

Many thanks in advance!


#344

The SDCard should contain two drive’s. One which Windows PC cannot read (hence the warning to format, just ignore that warning). And one drive containing the boot directory for hassos.

So after you click the cancel / ignore button on the format warning there should be an additional drive mounted in your PC.


#345

Nah, that doesn’t happen here. There’s just a prompt up trying to force me to format the SD card, no additional drive. I’ve ordered a new SD card, flashed HassOS and tried it there too, same result.

Furthermore I’ve read that there is no boot partition and no config.txt in case of HassOS, so I’m confused.

Maybe it’s just possible to add those lines in hasspian ?


#346

Hi there,
After running Zigbee Shield / ZHA few months with quite large setup, and also tested this zigbee2mqtt / CC2531 - it is time to give this Deconz/Raspbee a fair try. I started yesterday with new RPi / Raspbee, installed Hassio and official Deconz add-on. Everything started very smoothly. I paired for test purposes couple xiaomi sensors, switches, Osram smart plugs and Ikea light bulb. Works great.

I was a bit disappointed with WebUI. I works very well but after seeing nice pics to describe mesh etc. - This looked quite “plain”.

I have tried to read all this but there are just too many post to go thru - what makes it a bit confused is that I would like to know the difference with Official and Marthoc add-on. I would appreciate if someone could describe the difference with couple words if possible.

Also I read somewhere that you can update for instance firmware for Ikea bulb with Deconz - how do you do that? I did not find that in WebUI …

Looks and feels great though


#347

Great choice! The addon is the same as marthoc addon. It has been accepted as an official addon. Vnc will be added shortly so you can view your mesh as well.

With the official addon you’re supposed to be able to upgrade fw as well.