Deconz for Hass.io


#144

Hi

I tried to install your addon, I added your repo do hassio, it shows up, deconz addon I try to install but I got problem:

ERROR (SyncWorker_12) [hassio.docker.interface] Can't install marthoc/hassio-addon-deconz-armhf:2.05.28 -> 404 Client Error: Not Found ("no such image: marthoc/hassio-addon-deconz-armhf:2.05.28: No such image: marthoc/hassio-addon-deconz-armhf:2.05.28").

What am I doing wrong?


#145

I’ve just verified that the tagged image for 2.05.28 is available on Docker Hub. Maybe your Hass.io instance is having some trouble finding Docker Hub?


#146

I have a strange issue with firmware update again.
Phoscon interface says there is a firmware update:

But when I run the script I get only this versions available:

Whose are the same already installed.
When checking logs in docker I clearly see these lines:


#147

Check first step in documentation, you need to manually look up the new fw file name and then specify it in step 4


#148

That is a bizarre problem - the new firmware should be listed as available in the flashing script… I’m not sure why it isn’t. If you specify the new firmware file name, what happens?


#149

Ok I understand why this is happening. First, you need to do:

docker pull marthoc/deconz

To update the image on your system to the latest (2.05.28) image which includes the newest firmware. Then run the flashing script again and it will be available!


#150

You were right, I figured out by myself when I undestood that the image used for flashing firmware was not the same installed by the hass.io plugin.
Firmware updated flawlessly


#151

In fact you could use the same image as the addon (it includes the flashing script too). It’s just more straightforward to point people to marthoc/deconz.


#152

Yeah that’s was the problem, all good now, great job keep going. Cheers


#153

I’m having trouble with my conbee not finding any devices. I tried installing deconz on windows too, and there it worked. Any thoughts on why it doesn’t work with the addon? I run hass.io on an intel nuc (however I found another person with the same problem running on rpi).


#154

Hello,

I am interested in using deconz instead of my Hue hub and my Aqara hub.

I have a Raspberry pi 3B running hassio. Will it work if I add a raspbee or conbee? Which is recommended please?

I have the following aquara items:
Human body sensor
Smart light switch wireless version
Smart wireless switch

I also have several varieties of hue lights (mainly new colour ones), and I am thinking of making a light strip with this gledopto zigbee controller

Can anyone tell me if al this hardware is likely to be compatible together?

Thank you,

James


#155

Yes all of that should work together. I can’t say for sure with that gledopto, but if it presents itself as an ordinary zigbee light it shouldn’t be an issue.

I always recommend the conbee over the RaspBee,one reason is that if you want to change from raspberry to another device the conbee is more practical, also there are some issues with raspberry and bluetooth and other stuff when using RaspBee


#156

Thank you. :slight_smile: I’ll order the conbee then - good point about the versatility of USB! Apparently hue hub can control gledopto so no reason I can see that it wouldn’t work - your reassurance is, er… reassuring!

Thanks,

James


#157

If hue supports it deconz should too


#158

Hi,

I’ve plugged the conbee in to my hassio Raspberry Pi and I have installed the Hassio add on. When I go to http://hassio.local:8080 (i.e., my Hassio IP address but port 8080) I just see a web page that says “Invalid Request”. Can anyone help with this?

Do I need to have set up the Deconz component already? I have not done that.
Or is it because I have not update the firmware on Conbee?

… Or could it be something else?

Thank you for your help,

James


#159

PS - here’s my deconz log:

[Hass.io] Starting deCONZ Hass.io Addon...
[Hass.io] Current deCONZ version: 2.05.30
[Hass.io] Web UI port: 8080
[Hass.io] Websockets port: 8443
libpng warning: iCCP: known incorrect sRGB profile
This plugin does not support propagateSizeHints()
This plugin does not support propagateSizeHints()
This plugin does not support propagateSizeHints()

#160

I did two things - update the conbee firmware by using a windows machine, and remove my zwave USB stick. This appears to have resolved the issue. I will try plugging the zwave stick in again later and see what happens.

Now time to reset all my philips lights!!


#161

@marthocoo I have just tried to install the new HassOS image for HassIO
Unfortunately I can’t get my raspbee module to work correctly in HassOS with deconz addon, I am adding the lines to disable bluetooth and enable UART in the config TXT but it won’t work this time.
Any ideas? Someone has tested it?


#162

I haven’t tested HassOS yet so I can’t advise, maybe someone else will test?


#163

I will get an additional raspberry and SD to do some testing with the Raspbee on HassOS.
@marthocoo I will report back to get advice so we can sort this out.