Deconz for Hass.io


#164

I have the same problem here using HassOS.

I cannot add any devices (i.e. a new IKEA TRÅDFRI remote control)
There is always on update:

  • from version 2.04.35 firmware 00000000
  • to version 2.05.31 / 22/6/2018 firmware 00000000

Here below there are logs of my container running marthoc/hassio-addon-deconz-armhf:latest (marthoc/hassio-addon-deconz-armhf:2.05.31 today)

00:58:50:494 Wait reconnect after firmware update
00:58:50:801 Websocket disconnected 192.168.1.5:57848 (state: 0) 
00:58:51:568 dev /dev/ttyAMA0
00:58:52:089 device state timeout ignored in state 2
00:58:52:607 New websocket 192.168.1.5:57875 (state: 3) 
00:58:53:040 device state timeout ignored in state 2
00:58:56:993 device state timeout (handled)
00:58:57:493 void zmMaster::handleStateIdle(zmMaster::MasterEvent) not connected goto OFF state
00:58:57:493 device state timeout ignored in state 4
00:59:14:258 Websocket disconnected 192.168.1.5:57875 (state: 0) 
00:59:16:056 New websocket 192.168.1.5:57882 (state: 3) 
00:59:18:011 Websocket disconnected 192.168.1.5:57882 (state: 0) 
00:59:19:548 New websocket 192.168.1.5:57884 (state: 3) 
00:59:19:983 Websocket disconnected 192.168.1.5:57884 (state: 0) 
00:59:21:365 New websocket 192.168.1.5:57886 (state: 3) 
00:59:22:291 Websocket disconnected 192.168.1.5:57886 (state: 0) 
00:59:23:947 New websocket 192.168.1.5:57888 (state: 3) 
00:59:23:993 gateway locked
00:59:27:723 Websocket disconnected 192.168.1.5:57888 (state: 0) 
00:59:29:611 New websocket 192.168.1.5:57893 (state: 3) 
00:59:34:735 GW firmware start update (device not connected)
00:59:35:243 GCFFlasher V2_11 (c) dresden elektronik ingenieurtechnik gmbh 2017/12/10
no device specified use RaspBee (/dev/ttyAMA0)
using firmware file: /usr/share/deCONZ/firmware/deCONZ_Rpi_0x261f0500.bin.GCF 
00:59:35:243 GW firmware update exit code 1
00:59:45:063 dev /dev/ttyAMA0
00:59:57:566 Websocket disconnected 192.168.1.5:57893 (state: 0) 
00:59:59:434 New websocket 192.168.1.5:57907 (state: 3) 
00:59:59:853 	/robots.txt --> HTTP/1.1 404 Not Found
00:59:59:853 Websocket disconnected 192.168.1.5:57907 (state: 0) 
01:00:01:712 New websocket 192.168.1.5:57910 (state: 3) 
01:01:55:063 dev /dev/ttyAMA0
01:04:05:062 dev /dev/ttyAMA0
01:05:43:862 Websocket disconnected 192.168.1.5:57910 (state: 0) 
01:05:45:793 New websocket 192.168.1.5:58093 (state: 3) 
01:05:45:807 Websocket disconnected 192.168.1.5:58093 (state: 0) 
01:05:47:793 New websocket 192.168.1.5:58095 (state: 3) 
01:05:49:306 GW firmware start update (device not connected)
01:05:49:783 GCFFlasher V2_11 (c) dresden elektronik ingenieurtechnik gmbh 2017/12/10
no device specified use RaspBee (/dev/ttyAMA0)
using firmware file: /usr/share/deCONZ/firmware/deCONZ_Rpi_0x261f0500.bin.GCF 
01:05:49:784 GW firmware update exit code 1
01:05:50:496 Wait reconnect after firmware update
01:06:00:062 dev /dev/ttyAMA0
01:06:00:496 Wait reconnect after firmware update
01:07:07:569 dev /dev/ttyAMA0
01:07:08:070 device state timeout ignored in state 2

#165

I didn’t had time for testing but I am quite sure that on HassOS we are not able to use /dev/ttyAMA0 from Deconz container.
@marthocoo do you have suggestions on how to do some troubleshooting on that?


#166

I’m not an expert of deconz and HassOS, but I’m happy to help the troubleshooting


#167

Solved the problem by adding “dtoverlay=pi3-miniuart-bt” line to config.txt


#168

I am using @marthocoo add on and I have added Xiaomi sensors and Hue bulbs. Xiaomi works all the time, but I some times loose the connection to hue bulbs. I suspect it might be because I have one bulb, which is the closest to the Conbee USB, that sometimes is powered off from the switch so it is unavailable. This seems to cut off all the hue bulbs and all of them are unavailable.

Can that be something with deconz that if one is unavailable it deems them all that way or can it be because the bulb is a repeater and thus all of the other hue bulbs is rendered unavailable if the repeater goes offline.

I can’t seem to find a way via the add on to see the deconz interface where I would be able to see the zigbee mesh, but am I missing something there?


#169

It could be that you disrupt the mesh and it takes some time for it to heal.

Right now you can’t get the desktop gui from the container.


#170

It makes a lot of sense as the bulbs become unavailable pretty quick after I power off the closest bulb. Last night it had overnight to heal, but that wasn’t enough. Is it possible to force a heal as with z wave?


#171

I haven’t seen any command similar to the zwave. I will create a topic with Dresden elektronik and ask them how it works


#172

Cool, will be exiting to hear :slight_smile:


#173

Got a response yesterday https://github.com/dresden-elektronik/deconz-rest-plugin/issues/770

The mesh should heal on it’s own. When routing fails new route discovery from the source node to the destination node will be started. This may take a while and prior to route discovery several attempts to send an request might be made.

Thats the theory :slight_smile:

In practise meshing between different vendors has been challenging, the spec leaves some grey areas for interpretation so not all products work the same, mixing IKEA and Philips has caused troubles in the past. With firmware updates this will hopefully improve over time.


#174

raspbee works without issue (only two hue lamps so far) with the rpi2. Didnt get it to work with rpi3 b+


#175

You need to turn off bluetooth,

Check out this documentation https://github.com/marthoc/docker-deconz#configuring-raspbian-for-raspbee


#176

Is this still the easiest way to install DeConz om Hassio? I have done a new install based on HassOS and would like to continue where I left off with all my Xiaomi products.


#177

There is only one way?


#178

Ok. I understand. I tried to install according to the most popular link (https://bitbucket.org/jongsoftdev/hassio-addon/src/7e7bc50056e17fbacce26b087835e3b805392107/dresden-deconz/?at=master) in the replies. I got this error message:

18-09-09 22:18:31 ERROR (MainThread) [hassio.addons.addon] Addon local_deconz not supported on aarch64

I Couldn´t find anything in any post about this error message. Any clue?


#179

I have the same problem, the current implementation of the add-on doesn’t support the 64-bit version of hass.io but it appears that they are working on it.


#180

Is there any news on this?
I’m migrating to the nee hassos but this is kind of a big setback…


#181

AFAIK Mark is changing living accommodations right now, and that is why business has been slow


#182

Well that has to hapen too :wink:

just to confirm i’m not struggling with an other issue.

On hassos, the deconz add-on does not work. I can install it, run it, but my conbee is not detected,


#183

I am on HassOs on a pi 32 bit and deconz works fine with a conbee stick :slight_smile: