Deconz in HA light status not working


I have multiple Nanoleaf Ivy bulbs + 2 other color bulbs setup in Deconz/Phoscon running in docker on a Synology NAS (conbee II stick).

All those bulbs are working perfectly if I use the Deconz/Phoscon web interface to change the status/color/brightness but under HA it’s not working well!

The status of the bulbs are not correct and I cannot choose the colors for the 2 color bulbs.

I’m using the deconz integration which detects all the bulbs but apparently they are not configured correctly inside HA.

Do you have any idea how I could fix it? I updated the conbee II firmware, restarted multiple times my deconz and HA, same result.

Thanks for any help.

edit: Ok, now I know that something is wrong in HomeAssistant! I was able to connect to deconz using the Hue Essentials app (appstore), and from there everything work fine (through the deconz API), so there’s definitly something wrong with HA deconz integration…

What version of HA?

An issue related to displaying state of certain devices in Lovelace after 2021.12.6 is being discussed in the 2021.12.x thread.

Hi NathanCu,

I’m running HA 2021.12.6. I updated it today hoping to solve the problem… and before that I don’t remember the version I had installed but I installed it ~1+ month ago.

I also tried with a ‘clean/new’ installation of HA, but the result is the same!

Really, I don’t know what I can try next…

I think I solved my problem.

I configured my deconz to use a specific port for ssl, so I had something like that in my docker-compose:

   - 8087:80
   - 7443:443

I changed that to:

   - 8087:8087
   - 7443:7443
   - DECONZ_WS_PORT=7443

The problem with the initial configuration was that when HA ask deconz (through the REST API) for the websocket configuration to use, deconz REST API was replying with port 443 (which was wrong… as the exposed/external port is 7443).

I preferred to make all the ports match… (not necessary but more straightforward)

I still don’t understand why it was working for other apps (like the hue essentials I tried)

@NathanCu, I think I also have the issue you’re mentionning. The HA UI is not updating automatically… I have to refresh the page/dashboard to see the right light status.

I believe it was fixed in 12.7 but in not 100% positive. Today is my first day off. So i haven’t followed up on it.

1 Like

Just chiming in here, much delayed, as I was having the exact issue as OP on 9.6. I have the same setup too. And just like that, matching the ports from the container to host in the deconz container fixed it… I don’t quite understand why either. But it now works!