deCONZ - Official thread

Upgrade from 0.103.6 to 0.104.2 and everything seemed well.
Then I rebooted my Hassos VM because of unrelated NUC/Proxmox memory upgrade, and now HA cannot connect to deconz anymore:

Error connecting to deCONZ gateway at
Config entry for deconz not ready yet. Retrying in 5 seconds.

while in the phoscon UI the gateway and all sensors and lights are available.

Restore to 0.103.6 fixed it again.
Can anyone confirm that the 0.104.2 upgrade and deconz survives a hassos reboot?

Yes, it’s on an extension lead which did help a little. All my mains powered devices are Z-Wave, and I don’t want to change them as they are working fine. All my deCONZ devices are sensors (door, motion & water leak) as I like their price and response times - noticeably faster than Z-Wave.
I tried using a CC2531 with an external antenna as a router, but devices don’t seem to connect through it.

hey all,
im running a conbee2 with the Hassio Addon.
i can access it via the UI and my lights work
however the motion sensor doesnt (Philips Hue Presence sensor - state doesnt change from "detected" · Issue #2322 · dresden-elektronik/deconz-rest-plugin · GitHub)

can someone help me with how i can check what these are via the rest api please?

The sensor should send a message when it no longer detects motion, which the REST API plugin picks up to reset state.presence . What is the sensor’s config.delay value?

Hi all!

My Aqara switches are driving me CRAZY! Please, I need some expert help:


  • HASSIO Latest Version on Rasberry Pi 4
  • deCONZ Latest Version + Conbee II Latest Version Firmware
  • Devices connected via deConz: several lamps (various models), 1 Osram Motion sensor per room, and 1 Aqara WXKG03LM (single rocker) switch per room, plus an additional Aqara WXKG02LM (double rocker) in the kitchen (controls 2 devices in the back yard).

The Aqara switches are connected to their corresponding light automations through the deconz_event trigger, which then run some scripts.


- alias: Living Room Switch ON-OFF
  description: ''
  - platform: event
    event_type: deconz_event
      event: 1002
      entity_id: sw_living_room
  condition: []
  - service_template: >
      {% if is_state('light.living_bulb_light_1', 'on') %}
      {% elif is_state('input_boolean.livingroom_scenes_auto', 'on') %}
      {% else %}
      {% endif %}

Now everything was running smoothly until I added some additional Aqara switches. Now seemingly random switches fire random or even multiple automations to which they are not connected in anyway. For example, my backyard switch turns on the living room light, etc.

There is not even a similarity between two entity_id names, so, I don’t understand how that switch triggers that automation. It’s driving me crazy!

It seems as if the deconz_event trigger ignores the entity_id I put there and triggers no matter what.

Anyone had any similar experience? I need to understand if it’s deconz the problem, or my switches, or something else. Any ideas?

Thanks a lot!

This is my conf:

    - platform: event
      event_type: deconz_event
        id: smart_switch_blabla
        event: 1002

I’m using ‘id’ instead of ‘entity_id’

1 Like

I’ve had some issues in the past with duplicate groups, I was able to query the Rest Api with this info:

So basically first ssh into hassio, then from there I used curl, you can find my queries in this thread

I have upgraded to 104.2. Now All my deconz devices get unavailable every hour for 1 or 2 minutes. Has anyone had this behavior?

1 Like

There is no changes that should cause this. This is something with your environment or other integrations

I have had no other changes in my system. Never the less I will try to find the origin.

Yes, i’m seeing the same thing too. I’m running both home assistant & deconz in docker containers and have updated both , so I’m not sure whether it’s HA or deconz that’s causing it.

In the deCONZ logs i keep seeing this around the time of the drop out

20:03:22:865 Remove websocket after error Unknown error

I need to look through the HA logs too, but they’re pretty hard to follow using less or tail when debugging is enabled. The formatting is a nightmare as the log entries don’t seem to start on newlines (maybe just my setup?).


I’ve been following the logs and looking for some clues. The first occurrences of the devices going offline coincide with the time i updated to 104.2, so i’m going to rollback to 103.2 to see if it mitigates the issue.

I use IKEA repeaters and they work well!! (3 floors house). Suggestion with Xiaomi devices: make the association directly in the spot where the device will be used; it will connect to the local router during the association.

1 Like

I will also try the same. Please update the results and I will do the same.

One more thing: did you get the error in the log by using debug mode or just a standard error? I don’t have any errors other than errors in other component that use sensors from deconz.

The log message I’d pasted into my comment was from the deconz logs.

Jus checked deconz logs and have the same error

19:20:42:923 Remove websocket after error Unknown error

19:58:07:128 Remove websocket after error Unknown error

20:58:16:152 Remove websocket after error Unknown error

Don’t have a clue on what might be causing.

I can now confirm that errors on deconz started when I upgraded to 104.2 (I have been running deconz container for some weeks now without any restart, so I can only assume that the error has it’s origin on home assistant 104.2)

I’ve got deCONZ running in a docker, using ports 8080 (instead of 80) and 8443 (instead of 443). Home assistant configurator isn’t seeing it - is that because of the port change? Is there a way to direct home assistant to look for deCONZ on those custom ports?

Good morming, I’m using deconz on Raspbian (terminal only), everything is working fine. How can I see the mesh map of my devices? Could you kindly help me?

Go to deconz addon and configure this:
Install TigerVNC Viewer on your Notebook/Desktop

Thank you for your reply. I was able to see the map but, i can just see sensors but not edges to the gateway. Where can i see the signal strenght? Is the “Power level” property?

The signal strenght is represented through the color. Green is best. Red is worst.
I don’t know what you mean with edges to the gateway.
You should see something like this:

Mine is something like this:

In raspberry I stopped deconz service and started deconz-gui service to access this.