deCONZ - Official thread


Another question:
What happens with all my automations, if I always use devices as trigger or condition instead of entity name (e.g. light.doorlight) and have to remove (or re-pair) and add one ore more of my zigbee lights/sensors/switches? In the past, I always had to edit/update my automations because the zigbee devices will get a new device ID.

If you remove the device from deconz and restart hass the entry will be cleaned up

I know that. But I want to know if the device ID will change.

Whats my problem:
Sometimes one or more of my window sensors (Xiaomi) or Hue dimming switches (Philips) stop working. Then I have to start a new paring procedure in Phoscon (without deleting the device in phoscon or HA). The “re-paired” device is displayed as a new device with the standard name (the old device name disappear). I give the device the old name. What happens with the device ID in HA?

If I always use the entity name in the automation everything is ok. But if I use the device ID?

If the device entry gets cleared from hass you will get a new ID.

Though I think if you don’t have auto add of new devices in to hass there shouldn’t be an issue. You might be pointing out a situation I don’t really cover with the integration in the best possible way right now; readding a device without removing it

Hi, I just got my Conbee2 (to use with Aqara door/window sensor) and I connected it to a test RPi running hassio supervised, I installed deCONZ addon, started the addon with "device: /dev/ttyACM0", it worked well, so I configured deCONZ adding two sensors and everything worked well. Then I tried to add the sensor to HA, by authorising the API and I noticed that a new firmware update was available, so I updated it, and nothing worked anymore. Looking in the hardware section of Supervisor, the usb ports keep changing and I can’t find one that actually communicate with the conbee.
I changed RPi (from 2b to 3b+), I tried a long USB cable, but nothing changes.
I googled about faulty firmware upgrades for conbee, but there’s no mention of such issues.

Downgrade the firmware back. I had the same issue.

1 Like

Anybody having problems upgrading to firmware 26660700? When running it kills my homeassistant instance completly. Running on Proxmox

does the VM crash after you run deconz with the conbee plugged in? I encountered that issue after a firmware upgrade, the usb keeps reconnecting and the VM where it is passthrough on proxmox 6 usually crashes. See the proxmox syslog if the usb keeps on reconnecting.
See here - it seems updating pve-qemu-kvm to 5.1.0-1 or higher fixes the VM crash. I haven’t tried it yet though.

In the past I tried from several different VMs (Windows running on Mac in Parallels, Windows in VMware, phoscon add on in HA running under VMware) and none of htese worked. The only solution was to connect conbee to physical laptop running Windows, install phoscon and perform update according to instructions.
The most recent update, one you mentioned, I eprformed directly from phoscuon UI running Ubuntu on bare metal. Again warked flawlesly. That was one of reasons I decided to move to physical machine with deconz.

OK, another strange observation since I’ve migrated from HA addon to bare metal installation; once in a while (happened 3 times already over past 1.5 month) for no obvious reason all of the lights and switches go on… in HA and phoscon, but not in reality. State of all zigbee entities changes to on (including triggering automations on going to on state), but in reality all these entities stays with their current state.
Very odd and building on top of my frustration that not always state of the entity in HA reflects reality.
As far as I understand flow of information looks following: physical Zigbee device -> conbee stik -> deconz -> phoscon -> home assistant. To my observation problem is on the connection between stick and deconz or deconz and phoscon. State and actions seems to be consistent between HA and phoscon (so also phoscon can show false state of device, so it is propely reported in HA). Any idea of WTH is going on? BTW I’m running zogbee now on bare metal Unbuntu server, so no issues with communication between VM or addon through several layers of virtualization.

Phoscon is consuming information in the same way as hass. From Deconz.

Well, so what I suspected… But how this can gets stabilized… As I recall some point in time it was rock solid and is getting worse over time… I guess complains should go to Dresden Electronik :wink:

1 Like

Yeah hass only represents what it gets told from Deconzmaybe if the light gets disconnected from Deconz for some reason. I don’t really knoe

I have 100 devices on a Conbee II with Deconz running on bare metal (On a Debian 10) on a NUC. I recently upgraded from a Celeron to an i5 NUC. And on both I have never seen any of the problems you describe. I had trouble when I ran in the Addon. But never since.

The only Deconz problems I have had the past year is that it requires multiple attempt to pair a Philips motion sensor so all functions get loaded and there was a few weeks where the Opple remote controls were not working but the devs followed up on that quickly and they released a fix quickly. I love my Deconz.

@KennethLavrsen, actually several of your post convinced me to move to bare metal and to be honest it is way more stable than while running it as addon… yet far from perfect… Actually there are few things that come to my mind:

  • I’m running Ubuntu server on Atom based old media PC… wondering if this is good combination… but other than deconz issues I have no problem with this machine. Anyhow this could eventually explain issue with all zigbee devices going suddenly on (as phoscon thinks), but rather not stability of individual devices problem.
  • Mesh should not be a problem , as I have quite dense network with lots of device being relatively close to each other. Despite this, I observe problem with for example 1 light in group of 6 being 50 cm from each other. I also some time ago reconfigured my WiFi network channels to eliminate problem with potential interference.
  • Tradfri… all of the problems I have I do have with Tradfri lights. Other than that I have some Tradfri sensors, LED drivers, switches, outlets and these behavies properly (unless battery need to be replaced), which leads me to question of eventually some outdated firmware on these lights? On the other hand it supposed to be automatically update by deconz (if I understand process properly), so should be OK.
1 Like

Does anyone know a good CE approved Deconz compatible floodlight in the EU. I know HUE has one, but I don’t think you can pair it with Deconz. So far I have used zigbee smartplugs and -switches in my system but it would be better to have the light itself using Zigbee.

You can use the Hue floodlight with deconz. Typically all Hue devices work with deconz.

Thanks Robban!

I know Hue mostly work with Deconz but I read somewhere that floodlight does not pair with Deconz. Something that there is no reset switch or way to start the pairing process. Do you know for sure the Hue floodlight works with Deconz?

I usually re-pair my hue floodlight with the hue dimmer switch. I believe I was able to pair the flood light when it came out of the box.

OK Thanks!

Yes, I think I read your were able to pair it from the box but the problem was if you needed to re-pair the light there was no way to do it. I do not have Hue dimmer switch. So do you mean you can’t pair it with Deconz without additional dimmer switch. To be honest I do not exactly understand how this dimmer switch would help, I have always paired my devices directly with Deconz.