deCONZ - Official thread

Ok, I’ll.give it a try thanks. Will I have to re-pair all my devices ?

If you’re able to backup your Phoscon stuff, you should be able to get back to where you were (I believe). Although I’ll be honest, I did start over when I went this route, but my reasoning was that I had stupidly forgotten to back my stuff up in the first place. So, I never had a chance to try that out.

I might do this down the road. I had some issues with deCONZ 3 versions ago (1 second disconnects every few hours, but reconnected automatically). But for the last few weeks has been rock solid.

Might be worth it to get a second RPI4 and install deCONZ there through Raspbian. Keeping it nice and up to date and not be dependable of the add-on in HA.

For those having the issue where deCONZ seems to shut down at random intervals… do you also use the ESPHome addon?

I was working on a new device in the ESPHome web interface earlier today and I saw a notification that it had found a new serial port (the Conbee II is a USB-Serial adapter). This was strange because I run Home Assistant on a NUC which has no serial ports. Then I noticed that none of my Zigbee devices were responding so I checked in the Supervisor panel and found that deCONZ had stopped. After restarting deCONZ and letting the mesh rebuild everything was back to normal but I made sure to stop the ESPHome addon when I was done working with it.

For anyone experiencing the random deCONZ shutdowns… check to see if the ESPHome addon is running on your system; if it is, stop it and only start/run the ESPHome addon when you need to flash a device. There really is no reason to have the ESPHome addon running when you are not programming devices as devices can still communicate with the api/Home Assistant without the addon actively running.

I’ve done it, worth a try

I don’t have esphome, and exhibit shutdown of the add-on too, so not related… The add-on is stand alone, so not other component is able to interfere

Yes, I’m seeing this and I’m running the dev version of ESPHome. I’m also running on a NUC like you. I’ll try your suggestion and only run it when needed.

Anyone could answer me about the upgrade of marthoc/deconz container on my Synology NAS ?

bought some xiaomi multi sensors, but i dont see the battery state? isnt it provided by deconz?
i have other xiaomi sensors, like pir/water, i see the battery fine there


It is supported, sometimes it takes up to an hour for them to appear in HA. If not I’d try to reset and re-pair.

you are right, indeed, need to wait :slight_smile:

This thread is a monster!
Well, as I only use deconz to monitor two temp-sensors and kept my stupid IKEA Tradfri gateway for all the switches and lamps I still somehow manages even with all the issues with deCONZ.
After last update, my deCONZ plugin just refuses to start, no logs, just will not start. Tried disabling the VNC port as mentioned above. Still won’t start.

Now when there finally seems to be a fix for the “dropping all entities after reboot”-issue a new issue appears:-(

Any ideas? Unistall addon and install again maybe? Just so fed up with this s-t.

btw, fix for “loosing all entities after reboot”-issue, mentioned above

Didn’t check it my self (obviously, as deCONZ doesn’t start right now)

Hi Frederic,
Try to start the addon and then check what the supervisor log says (Supervisor -> System)

Thanks M1ke,
A, there we have some logs!

[supervisor.docker] Can’t start addon_core_deconz: 403 Client Error: Forbidden (“endpoint with name addon_core_deconz already exists in network hassio”)"

Googled around and found ppl with similar issues with other addons. Installed Portainer but when uninstalling the deCONZ addon also seems to successfully remove the docker image, at least, as a newbie, it looks like it is executing the uninstall correctly.
Re-install, bam, same error.
I might, of course, be looking at the wrong place in Portainer as I never used this tool before.

Hmm, very strange… After you uninstall the addon and then in Portainer go to Network -> hassio, are you still seeing deconz?

Nope, it’s never seen under network. Even when re-installed as it never manage to start. (and yes, I removed all hidden containers in the Portainer settings). Yes, very strange.

Right, at least that’s how it should be then :wink:
Sounds too easy, but have you tried to restart the host machine? As the dev of the google drive backup addon said here, this seems to be a bug in docker and might be resolved with a supervisor/host restart. Also suggested here.

1 Like

Restarted HA MANY times but never did a full re-boot of the pi. It solved it! Thanks for your help M1ke!

1 Like

Fantastic! Hopefully the other issue you mentioned does not happen anymore :smiley: