Deconz vs zigbee2mqtt (with Conbee II)

I’m curious if anyone jumped from deconz with the Conbee II over to zigbee2mqtt with the Conbee II.

deconz is great and really stable for me, don’t get me wrong, but zigbee2mqtt seems to have a much wider array of devices, especially for US users, whereas “most things” work with deconz with the attitude of “give it a try, it should, but if not request a new device be added.” There isn’t much of a definitive list of what does and doesn’t work with them.

I’m not knocking the deconz folks at all, I’ve done just that type of request and in the next beta there it was and working. I’m just looking to add a little more “certainty” on my side when it comes to adding devices.

Database of Zigbee devices compatible with ZHA, Tasmota, Zigbee2MQTT, deCONZ, ZiGate and ioBroker (although not definitive this site is quite thorough)

I agree though that z2m seems quicker to add new devices.

Conbee is still listed as experimental for z2m here Supported adapters | although there seem to be plenty of people using it successfully.

It seems deconz is working towards an easier way to add new devices. Check the latest release notes about the upcoming 2.13 release.

There is some chat in their forum about the blakadder site and that it isn’t accurate for some deconz items. I was already aware of it and added a couple of things I confirmed working with deconz to it.

I hadn’t realized that they JUST updated deconz 2 days ago, however. New firmware too. Guess I’ll go give that a whirl!

Then they have to submit/confirm it is working with deconz. If nobody confirms, the site can not be updated.

Recently switched from deconz to Z2M with a Conbee2 and can say that Z2m is a more advanced solution. It adds devices quicker, doesn’t have the limited UI that Phoscan has, is compatible with a much larger library of devices (like a SmartThings/ADT water sensor for me) and has much more info about your devices displayed in the UI. I also like how easy it is to add new custom devices if you have one that isn’t yet documented.
My only con was that there wasn’t a single walkthrough install guide that covered the conbee2 so it took some time to get it set up.

1 Like

Thank you, that’s the info I was looking for. If I go for it, I’ll probably go with a separate docker install on a Pi away from Home Assistant; that’s how I do my zwave2mqtt. Although, I might wait a bit and see how the deconz updates go. They seem to be moving towards a better way to handle devices too.

1 Like

I’m starting with HomeAssistant. Although the integration is deConz, I wanted Zibgbee2mqtt, a conBeeII + Mosquitto broker. Using google, I worked out that it “works” for me. I have a test socket supported by conBeeII type Smart Plug TSF011F. I’ll look for a device in Zigbee2mqtt and nothing happens. Am I wrong somewhere?
Can I know how you have it configured?
I am a beginner.

Rapsberi PI 4
[Balena Etcher] + 6.5/haos_rpi4-64-6.5.img.xz
Thank you.

Look at the hardware info in supervisor.

this should probably be fine because Zigbee2mqtt will create an adapter:
ttyACM0 / dev / serial / by-id / usb-dresden_elektronik_ingenieurtechnik_GmbH_ConBee_II_DE2250000-if00

conBee II firmware 2021 revision 0x26720700

Debug Log:
Zigbee2MQTT:debug 2021-10-26 03:39:14: Using zigbee-herdsman with settings: ‘{“adapter”:{“concurrent”:null,“delay”:null,“disableLED”:false},“backupPath”:"/config/zigbee2mqtt/coordinator_backup.json",“databaseBackupPath”:"/config/zigbee2mqtt/database.db.backup",“databasePath”:"/config/zigbee2mqtt/database.db",“network”:{“channelList”:[11],“extendedPanID”:[221,221,221,221,221,221,221,221],“networkKey”:“HIDDEN”,“panID”:6754},“serialPort”:{“adapter”:“deconz”,“path”:"/dev/ttyACM0"}}’

data_path: /config/zigbee2mqtt
external_converters: []
devices: devices.yaml
groups: groups.yaml
homeassistant: true
permit_join: false
base_topic: zigbee2mqtt
port: /dev/ttyACM0
adapter: deconz
log_level: debug


I don’t know if it is yet supported by Zigbee2MQTT.

I looked here:

It’s just that nowhere on that product is it written that it’s TS011F. It’s from aliexpress …
The product bears the label Smart Plug 16A … Made in China …

And you can’t pair it ?

HA - Zigbee2mqtt pairing (Join button). Smart Plug by pressing the button until the LED flashes. Zigbee2mqqt counts down and finds nothing. Distance from conBee about 1m
I tried two of these sockets …

I’m sorry. After a two-day match with the socket and the belief that it is a Tuya Smart Plug 16A EU (TS011F). So I installed conBee II on a PC with deConz software. There was no pairing, although optically and according to the packaging it should be. I also looked at There it is, it’s a Wifi Plug. Debug in iot TUYA also didn’t reveal anything …
So I removed the HY369RT ZIGBEE thermostat from the TUYA app software. Pairing occurred in deConz and HA. But in reality it is HY369TRV TS601 _TZE200_ckud7u2l. HA accepted, but there is an error PayLoad '{etc. in the logs. } 'is not a Number … :roll_eyes:

As a result, conBeeII + Mosquitto + Zigbee2mqtt works fast … only those zigbee devices are not compatible, even if they look like that :grinning:

zigbee2mqtt has very clear instructions on how to add unsupported devices.

Payload is not a number is a known bug that will be fixed in 2021.11

I am a beginner. I’m glad I broke up after a week, at least as it is … I saw it somewhere … Thank you

well thank you for the information

I’m playing with socket looking like TS011F
I tried to pair them with deCONZ (Phoscon App) sw and conBeeII with the latest FW. SW will not find anything. Tuya smart app yes, but it doesn’t provide information about what it is.
How do you find out what kind of device it is? (Zigbee ID, etc. data?)
When i paired in HA with conBeeII HY369TRV and then inserted in PC with deConz sw appears HY369TRV in it. It follows that paired devices are stored in conBeeII. This is because if the conBeeII firmware does not have a saved definition of other devices, they cannot be paired …