Default home zone

During HA installation it retrieves location coordinates from somewhere… I’m not sure but those values are bit off. I figured this out recently when working with NodeRed. I expect node red get’s this information from HA. Maybe I’m wrong but it’s not my main question.

Question is: how can I change coordinates of home zone, incl. altitude and especially radius?
Looks like all additional zones has such features.

Anyway, here is what is stated in official documentation:

If no configuration is given, the zone integration will create a zone for home. This zone will use location provided in the configuration.yaml file and have a radius of 100 meters. To override this, create a zone configuration and name it ‘Home’ .

First 2 sentences are bit contradiction and actually not completely true. In my case no configuration is given, no zone record in configuration.yaml, but for some reason I have default home zone, which is called “Domov” (Czech language). Where this name is coming from? The rest of GUI is in English (which I prefer)

3rd sentence doesn’t make things more distinct. To take control over my home zone do I have to create entries in configuration.yaml (I suppose it’s old school approach), or should use visual editor to add zone named “Home” which will override default one? Is using “Home” word obligatory? Or I must use the same name as default zone (Domov)

thanks in advance

anyone knows?

Go to the ui select the gear symbol on the left sidebar then select zone. You will be able to edit both the position and radius as well as add more zones if you choose.

The UI doesn’t allow me to modify Home zone radius. Or I don’t know how to do that. I can only move the zone around on the map, but since there are no coordinates displayed, I must ask: does it set altitude too?
Also edit option is disabled (greyed out)

I didn’t realize the home zone was fixed. If you want to input the numbers directly use the configuration file as per . You can also set the elevation there.

And how would one set the radius then?

I don’t know that you can change Home radius from the fixed 100 m. At least I’m not aware of how to do it. Any other zones you can change the size by clicking and dragging the radius boundary on the zones map.

I’ve found a solution. Not pretty if you ask me.

In the UI go to configuration>customizations and on that page find your home zone in the pulldown. Then you can override the default radius.


worked for me…perfect and simple

1 Like

This worked a treat for me… Thanks @frits1980

1 Like

that work beautifully. at least on the map pin and on the UI. i will test it tomorrow for actual results. thanks

1 Like

Thank you :slight_smile:

1 Like

It’s not really necessary though.
You ALWAYS override the Home Zone by adding it to the zones.yaml file, it will override whatever default Home Assistant has picked, and since you can define the radius in the zones.yaml file, this is the correct way to do it:

  - name: Home
    latitude: 32.8793367
    longitude: -117.2474053
    radius: 100
    icon: mdi:account-multiple

You are right! Thanks for pointing that out. I’ve deleted my post so users comming to this will thread will use the recommended way of overriding the Home zone in the zone: section of the configuration.yaml. I’ve overlooked it in the docs. Thanks!

1 Like

I’ve followed docs, setup zone in zone.yaml, but I still see the auto created Home zone and my yaml Home zone…



Delete all history, reload the system. That solved it for me. Restart Home Assistant!

What history are you referring to? Browser history? Or is there some history in HA that I need to clear?

Well I didnt do anything…that I’m aware of, and when I checked this moring, I now only have one HOME zone with the radius specified in my zone.yaml file. So all good.


Hi am new to HA i am trying to add a zone.yaml file but i keep getting an error when i check config
if i have the txt from the zone.yaml just in the config.yaml it works?
if i cant sort this out i wont be able to make any new yaml files.

thanks in advance

I suspect you’ve resolved this, but if not… remove line 1 from your zone.yaml file.

This is in essense a duplication of line 15 in the configuration.yaml file.