Deltaco SmartHome

I haven’t bothered configuring the LED and button on the power strip.

It is possible like the Brilliant / Mirabella Genio Smart Plugs here:

I bought 3 of these Deltaco sh-p01, really inexpensive and nice looking wall plugs.
After a little troubleshooting and reading in this forum I managed to flash the first plug. (this is now bricked because I flashed a bad bin trying to load ESP home on it :frowning: )

But the last 2 I cant get flashed at all…
I Start Tuya-convert
Then connect my Samsung phone to the vtrust-flash network
Put the plug in pairing mode

…when I start the process the wallplug klicks/blink and then it will time out efter a while. Like this:

SmartConfig complete.
Resending SmartConfig Packets

SmartConfig complete.
Resending SmartConfig Packets

SmartConfig complete.
Resending SmartConfig Packets

SmartConfig complete.
Resending SmartConfig Packets

Device did not appear with the intermediate firmware
Check the *.log files in the scripts folder
Do you want to try flashing another device? [y/N]

I have the same issue, not sure if it’s related to my environment or not. But it keeps timing out.

Did you buy from “webhallen” also ?
Do all of your have the same problem or did you mange to flash at least one ?

I bought mine from Mediamarkt (99:- a piece). Kinda expect it’s the same hardware revision though. Bought a P02 a few weeks back from Styrahem, only to realize they switched to a Realtek SOC instead of ESP. I started to suspect they switched to Realtek in these as well, but I just looked up the vendor from it’s MAC address and it was Espressif, so it should be ok.

So far I have only opened and tried one. At some point I figured that I try one just to see and perhaps return the other ones if I had no luck. I did activate this one and added it to the DELTACO app, so I’m gonna try flashing it again.

I’m using a raspberry pi 4t and my samsung mobile as donator device. Do you have the same setup ar something else?

Rpi 3 (running from docker) with iPhone X in my case.

New firmware from Tuya, just bought 2 Deltacos after following this thead and noticed they cant be flashed any more :frowning: read more at


Does this mean that we have to wait for a new version of Tasmota or are they now most likely to never be flashed ?

Got a 3pk SH-P01-3P but also no go with tuya convert.

new client on port 443 from
ID: 0242416f68626d64366147393149465231a29185a61862a0e3a08b63639651d30cb778467fb5138551f3a9693fce36a9c0
PSK: a2348bad936e6bfe01e64f3893920f43e2b7883a5565dc98bdb7b857b89e94fa
could not establish sslpsk socket: [SSL: DECRYPTION_FAILED_OR_BAD_RECORD_MAC] decryption failed or bad record mac (_ssl.c:1056)

Is there a breaking and entering guide to these? at a glance there are just two pieces to the shell and no accessible screws under non-existing stickers etc.

Damn, its glued or welded pretty much 360° around and after getting through that the prongs are soldered to the board with only a cutout to unscrew one of the two prongs. I.e. you have to de-solder the other prong to extract the board. At a glance I couldn’t see any test pads for programming without pulling the board out.

Edit2: adding pictures as this seems different to SH-P01

Anyone had any success with SH-LFE14C35?

How did you manage to open the sh-p01e? The blog post doesn’t exist anymore. Looking to flash two of these via serial since tuya-convert doesn’t work anymore.

1 Like

Hi guys,

Not sure if this helps any of you, but I have a bunch of Deltaco smart plugs that I wanted to get into Home Assistant. I got a tip to try to add them to Tuya directly in the phone app without doing anything – and it worked.

1 Like

Deltaco SH-P01E Teardown:
There is a “plug” that can be removed (pried off) to reveal screws.
then simply unscrew, and pull the top, off of the bottom.
This one uses a TYWE2S packge, it contains an ESP8285 according to some documentation i found.

1 Like

Damm, I couldn’t just add the SH-P01E to Tuya Smart Home like I could with the SH-P01s.

What is the blog post referred to above for the P01E? Anyway to get them into Home Assistant?

If you have some soldering experience and a programmet, an rpi Will work, you can manually flash tasmota in SH-P01E.

1 Like

Thanks, sorry for not updating, I just tried a few times more the day after and it worked.

Don’t think there is any need to flash the Deltaco plugs to get them into HA, I’ve at least been able to just add them to Tuya and through that integration to HA.

But that of course includes creating an account etc that some don’t, but I don’t care that mcuh about that.

How did you get SH-OP1 open?

I did not open it. I used tuya convert to replace the stock firmware with ESPHome.

1 Like

If you have the round one linke i posted here then you quite possible can’t open it non-destructively. I just revisited this to extract the TYWES2 module to use in another Nedis plug from Kjell&Co that had an incompatible module, at least i can salvage something as the shell was destroyed from opening.

If you have the square one others have shown then looks ike just the two screws under the cover.

I’m curious when was the ones that worked with tuya convert purchased; everything I’ve got the last year or so have either been patched or downright incompatible.