(╯°□°)╯︵ ┻┻ DeskPi Pro Active Cooling and Front USB ports

I struggled to get things working until I read this post in full. This would be worth including in the user documentation for this add-on.

I can only get it to work at first, but it broke once I restarted the hardware. I manually edited the config.txt when I did a fresh install of the HassOS onto an ssd. It finally detected the serial port. Everything worked fine. However, the addon stopped detecting the serial port after one restart. At this point the fans still ran but the addon could no longer detect the fans or adjust it. Another reset broke it completely. The fans stopped running after. I can’t possibly do a fresh install every time I want to restart the system. Am I really the only one facing this issue?

I spoke to the Deskpi folks and they told me that this is probably due to it no longer reading the config.txt when booting, and told me to do a fresh install. This is in line with what I am seeing, but I can’t possibly do a fresh install every single time I need to restart the system?

Does the config.txt still show the modifications? Enabling Serial also enables the front USB ports. Are you performing any USB OTG, or serial changes to HAOS?

I took the SSD out to check via windows once again that the line was indeed still in the config.txt. I put the SSD back in to boot it and now it works again. Mind you I’ve power cycled by unplugging the power many times, and made sure to have no other USB devices attached (aside from the one that connects the SSD to the raspberry pi itself), but it never worked. So it baffles me how random it is. I’m really grateful for your addon, and the continued support you try to provide. For now, it’s working but it leaves me very afraid of hard restarting home assistant going forward.

One thing that seems to get a lot of people, is you have to reboot the hardware twice. The first reboot emplaces files. The second hard reboot activates the I2C.

I have the exact same problem. I have installed everything as it should be installed (I think). My front USB-ports are working BUT the fan wont run… The fan is not faulty, it works but not with this case/addon.

s6-rc: info: service s6rc-oneshot-runner: starting
s6-rc: info: service s6rc-oneshot-runner successfully started
s6-rc: info: service fix-attrs: starting
s6-rc: info: service fix-attrs successfully started
s6-rc: info: service legacy-cont-init: starting
s6-rc: info: service legacy-cont-init successfully started
s6-rc: info: service legacy-services: starting
s6-rc: info: service legacy-services successfully started
Current Temperature 37 °C
nc: bind: Address in use
Quiet Level 2 - Fan 20% (Low)
Current Temperature 37 °C
Current Temperature 38 °C
Current Temperature 37 °C
Current Temperature 38 °C
Current Temperature 38 °C

UPDATE: I turned on Watchdog in the addon and voilá, the fan started to work… Pretty strange, but Im happy! :slight_smile:

Could be your fan is going bad. If it has more drag resistance than expected, it would take more power to rotate, meaning self-starting at 30% power may not be possible. Moving the fan physically may give it the starting force it needs if this is the case.

Try setting your min/mid/max to 1/max/max. This will force it to start at 100% power unless it’s really cold where you are.

After I installed my DeskPi pro yesterday I was very happy to find your add-on. Great since I was not sure how if I just could install the Deskpi Pro software in the SSH terminal. So I did give your add-ons a go. Must have done something wrong since I have a hard time getting it starting. See the error logs.
So what did I oversee or do I need to get this going? I have only a ssd attached to the DeskPi no other usb or serial devices for now.

You need to enable serial. You’ll know it works when your front USB have power. There are a few ways to enable USB serial, including an addon.

I have also installed the add-on (I think?). If you meant the Serial Converter. At the second image.

You have to disable protection mode on the configurator then do it all again.

Right :slight_smile: I assumed it already was disabled. Now it is working. Thanks. Any way to show the Rpi temp/ other info on a dashboard? Or have it send to influx.

There are several options to get s sensor for RPI temp. This addon only provides fan speed.

If anyone wants Always-on capability for the Argon One V1 case, I’ve been running this hardware mod for about 2-years. It’s simply a great way to achieve power-on on power-loss, or always-on.

Simply solder a wire from the edge of one connector to the edge of the other, and it just works.

2-years, no problems to report.


Thanks for the Add-On.

I’m having issues getting it to work, I put the DeskPi Pro jumper to “Fan FS”, ran the Serial Configurator Addon (turned off protection mode), pulled the power plug and restarted.

But for some reason no new USB’s are added, the only USB I have is the /dev/ttyUSB0, which is my Zigbee stick.

Anyone with some tips what to do to fix/debug this?

I’m running HassOS.

This is my list of hardware showing the USB’s: