Device_tracker and geocoded location 'Unknown'

after having updated the iOS app on one of our phones, the device_tracker and geocoded location sensor remain ‘unknown’

The other sensors work, and immediate I should add. connecting power immediately changes the state to Charging, proofing the sensors and device are correctly seen by HA/the App.

I did reinstall the app after having deleted it from the HA settings in the integrations page.

any hints as to what I could try to get it to work again? Pemissions are all on, all buttons show allow.

thanks

same for latest huawei mobile phone without google map.

1 Like

yeah no update on these entities still. already reinstalled after having deleted the integration and the app once more…

For what it is worth, I had the same issue. I was having inconsistent results with my device_tracker geocode location so I removed the IOS app and reinstalled. My geocode location was “unlnown” for quite some time until I rebooted my iphone, then it came back. You know this, but make sure you go into the “location services” on your phone for Home Assistant and set the “allow location access” to always.

My two cents.

Experienced something similar, just stopped working and always reported “Unknown” for me. Tried everything, enabling and disabling permissions and stopping/starting and rebooting.

Finally I solved it by changing the “Minimum Accuracy” it defaults to 200 and after changing it to 2000 I got my location and now I can see that my accuracy is reported as 600 so, that was my problem.

I dont know why my accuracy suddenly changed, but that not Home assistants fault.

But, I would be great if it still showed the position, and noted that its our of accuracy range.

I’ve just been having trouble with this and it was down to background location being turned off in the sensors section of the app configuration menu. This was Android but hopefully it’s transferrable.

1 Like

Where to change this minimum accuracy?