Device_tracker and mobile_app

Do the device_tracker support mobile_app integration fully in current version?
I can see my device_trackers from the mobile_app integration is not updating.

On one of my devices I have Device Tracker disabled in settings - HA still sees the mobile_app tracker but it’s not updated.
On another device I have Device Tracker enabled, this generates 2 device_trackers - the “old style” and mobile_app. Mobile_app tracker is not updating but the “old style” is.

@Ionut - any ideas?


Sorry for long delay, only now i saw this post. Mobile_app + device tracker is not yet integrated. For now the device is registered but it doens’t receive any updates. Very soon this will going to be fixed.

Makes sense I don’t see the updates then :wink: Any idea how long until it get fixed?

Until Friday for sure. I also work on some things which i am very excited but i think i can do a small update for this :smiley:

That would be great - in that case I’ll just wait it out and not enable the “old method” again (preventing dual entities)

I actually start liking Ariela more and more - it seems to give me what I have been looking for. Completely ditched IFTTT for buttons now :slight_smile:

I am so happy to hear that. I will give possibility for users to choose for old or mobile_app methods. Something like i did for the sensors & MQTT :smiley:

Ever since I switched to mobile app sensors I’ve been getting tons and tons of these errors. Could someone please suggest what’s going on and how to fix it? @Ionut?

2019-06-14 10:58:13 ERROR (MainThread) [homeassistant.components.mobile_app.webhook] Refusing to update non-registered sensor: 8062c760da84d9f118e3e878bc88e47fe94520317f81d5adace470a4ba13e7f5_mobile_app_galaxy_s8_availability
2019-06-14 10:58:13 ERROR (MainThread) [homeassistant.components.mobile_app.webhook] Refusing to update non-registered sensor: 8062c760da84d9f118e3e878bc88e47fe94520317f81d5adace470a4ba13e7f5_mobile_app_galaxy_s8_battery

Please tell Ariela version you have.

Version is

Please update to and tell me if problem still persist.

Will do. Should I force mobile app credentials after the update? Also, should I choose mobile_app or MQTT for each sensor or leave them both checked? Thanks!!!

Yes, please to force the credentials again.
Choose whatever you want, but i recommend using just one of them :slight_smile: Eg: mobile_app.

I’m having a problem with the latest version of Ariela Pro device tracker updating. The only way I can get it to work is is by having the Mobile App and the See turned on. I’ve tested this on and off all day and only having both on will allow it to work. Is it necessary to have both turned on or is this an issue?

You don’t need to have both of them enabled. You enable only the one you wanna choose for updating.

Exact same problem here. Ever since the last update, no matter if I choose “see” or “mobile_app”, I get a report from the tracker briefly only after hassio restart. From then on it stops updating … :frowning:

Have not tried enabling both at the same time, but as @Ionut says, it shouldn’t be required, right?

It doesn’t seem to be agenral connection issue as the “Ariela availability” sensor updates on the dot.

You can send me the logs, so i can check if Ariela sends updates to HA. If Ariela send the updates most likely its an HA issue

I doubt it is HA issue - the Ariela tracker was working flawlessly before the last update :frowning: There’s nothing in the log anyway - do I need to set up something specific in the logger component?

I will try to reproduce and see what’s happening. Btw, had you tried uninstall / install Ariela? And also clear cache?

Cool. I’ll try re-installing, but could you tell me how do I wipe clean my hassio deployment from all traces of Ariela. It makes a lot of sense to scrub both ends before starting anew, right?