Device Tracker does not update

Hey all,

I have a problem with a phone that does not update the device_tracker location (line 1 on the screenshot).
As you can see on the screenshot the geocoded location (line 3) ist updated when the phone moves out of a zone but the zone does not change for a long time (tested about an hour). It never changes to “away” or “not_home” (not sure what it should be).

The app has all rights to run in background etc.

Any suggestions?

start here:


Noticed that step 3 was incorrect. Make sure: Background Location, Location Zone and Single Accurate Location are enabled. High accuracy does not need to be as it only reflects the state of a setting.

1 Like

Yes I know.
Step 3 (Unrestricted Data Access) was the only option not enabled for HA in the phone settings.
Enabled this one too but I am not sure if this will help since it is not enabled on another phone either which works though.
But I will test and let you know.

sorry I meant step 4 lol, also your next steps are to look at the logs after checking the settings mentioned. The logs will tell you if we are getting location updates from google or not so they are a good place to start. If you dont see any location in the logs then I would go up one troubleshooting step and follow the start over steps

Yeah, I got you right on the first try. It’s 3 options in step 4 - can be confusing :sweat_smile:.

There is a typo in the docs. It has to be “LocBroadcastReceiver”, not “LocBroadcastReveiver” :roll_eyes:
The logs show the entries. At least now. We will see if this did the trick.
Thanks for now!

D’oh I’ll send an update for that in a bit

Glad it’s started to work for you

@dshokouhi Go ahead. I am not into editing the docs.

It seems, the app now stopped transmitting any data at all.



So I will try to start over later today. :unamused:

if you havent started over yet, I would start by checking the app configuration logs to see what errors are showing up

Worked for me. And from “Unknow” to “Home” but today I went to different places but the home address never got updated. Does anyone has any guesses? Due to this, it did not trigger a couple of automation I was expecting it to trigger. As shown in the steps I updated all the sensors, and the app runs in the background with no data or battery optimization.

From 5 to 10:45 I was at least 10 miles away but it still shows I was at home. I checked the crash logs but I cannot see the log before I came home, I don’t know why.

One of the automation it did not trigger is as follows:

- id: '1644567578'
  alias: Close Garage after I leave
  description: ''
  - platform: zone
    entity_id: device_tracker.note_20
    zone: zone.home
    event: leave
  - condition: state
    entity_id: cover.garage_door
    state: open
  - service: cover.close_cover
    data: {}
      device_id: 85eae1bdebc594afe38bc6a0649
  - device_id: 8f8fa4d7b3422077f62f943227a
    domain: mobile_app
    type: notify
    message: You forgot to close the Garage Door. Home Assistant Closed the Garage
      for you.
    title: Garage Closed!
  mode: single

any issue with automation apart from the location of the tracker not updating? If I run actions manually, it opens the garage.


This is a weird one, it used to work for me fine when I was using duckdns to access my HA instance remotely. I have subscribed to the cloud service and ever since, my companion app is not updating the location. I’ve deleted the device, reinstalled on my phone, no luck at all. Anyone else encountered this issue?

did you follow the steps from the second post in this thread?

Thank you for responding, I did actually and I can see location data in the logs for the companion app and it looks good. Just doesnt get updated in HA for some reason. All other information besides the location is fine though weirdly.

It used to be fine when I wasnt using the cloud, the updates were instantaneous. I wonder if there is a way to check the cloud logs?

I’m kind of glad to find out I’m not the only one with this issue!
Switched over to cloud mid-February, and since then the person.<name> never got updated away from home, although today I found out the device_tracker.<device> updates perfectly. Does the same happen to you too?

1 Like

It has magically started working now since I updated HA yesterday. I am usually keeping HA updated regularly so maybe one of the versions broke it. I have no idea. Let’s see how long it works for.

I have to admit I never had such issues before subscribing to the cloud service.

Has Anyone found a solution, then my location dosent update either with nabu casa cloud.
And there is no Update i could install

always start with the link in the second post when dealing with location issues

Yes i did all of that, when I’m Home in my local network my location is send properly, but when im away the log in the app says “failed to send”.
But the Remote Access over Nabu Casa is working just fine

when you are away look at the logs from Show and share log screen…that error should be helpful in understanding the issue when away.