Disable KNX tunneling

I’m working on ETS5 to configure the KNX devices. The problem is that I’m getting

The device cannot accept the new data connection because its maximum amount of concurrent connections is already used.

when I’m trying to partial download to the devices.
The only way I’ve to let it work is to comment out the knx on the configuration.yaml and restart HA, then do the download, then to renable the KNX in HA and restart HA.
Is there a better way?

You should have the ability to use the multicast adres within ETS5 (it will show your ethernet/wifi interface)
But what IP module do you have? That will only work with a router device

  • Some interfaces require activation of multiple tunneling connections. Mostly only very old interfaces provide only one concurrent connection.
  • If you have a router you could use routing (from HA or ETS) instead of tunneling.
  • You can just shut down HA, do ETS stuff and then start HA again instead of changing config for 5 minutes of ETS work :man_shrugging:

When you have configured knx in HA it will always try to keep its connection alive.

My IP module is a Crestron CI-KNX CI-KNX [Crestron Electronics, Inc.]
Not sure if it’s router device or not.

Thats a rebranded tunnel device yes. Seen it many times for Crestron and a few others
(i think the original is the KNX IP Interface 730 from Weinzierl, correct me if i’m wrong tho)
It should have 5 tunnels available. 1 is used up for each connection.
So if you have the Crestron system that will take up 1 and your ETS also 1.
And HA also 1. Thats 3 so they should be able to run together.

I know that GIRA and JUNG IP tunnel devices sometimes have to be reset to free up tunnels.
So might be worth to see if this is the case too. Tho be carefull as this can break the Crestron connection and you’ll need someone to fix that.

@Dujith you are right, it’s a Weinzierl 730. It should be able to support up to 5 connections, as stated also here https://www.weinzierl.de/images/download/products/730/Weinzierl_730_KNX_IP_Interface_Manual_EN.pdf

I’ve tried the procedure to add one additional connection (i.e. Press the learn key on the device longer than one second), but the led wasn’t starting to blink.
So I decided to reset the device using the procedure in the doc in the link. The problem is that now I’m unable to download to the device, as I’m getting “No ConnectResponse Received” after I press the programming button. Am I missing something obvious, or do you have any suggestions?

It might have gotten a different ip address? ETS should show you where it is and you test it there.
Make sure you ste a valid KNX address to, in default 15.15.255 it only has 1 tunnel at 15.15.250

I’ve changed the IP address to a static IP and I’ve also changed the Host individual address to the line. The diagnostic seems to be fine. My ETS skills are limited, so I’m running out of ideas :frowning:

Do you have an USB KNX interface? or another way to program the KNX bus as that would simplify the process alot. Also, what ETS version are you using?

If its ETS5 the KNX connection should look something like this:

Nope, I don’t have an USB KNX interface.
The other devices are working just fine.
I’m using ETS5. This is my connection

Those are my devices
Screenshot 2021-09-30 at 21.52.29

This is the error
Screenshot 2021-09-30 at 09.01.59

What does show details say?
Also it looks like it on the right address. Sometimes programming your own address on the device you are using to program does this weird thing where it sets the address but ETS doesnt think it worked.

You can try this out by downloading the application and not use the download all option.
Because it will try to program the address again.

Luckily I’ve manage to restart the KNX IP interface at the original state. So now it’s working correctly, but I’m still unable to add additional tunneling connections. Not sure if this is due the fact that I’ve downloaded the Crestron Application instead of the Weinzierl one.
If I’ve understood correctly, the KNX Crestron application is exposing up to 250 datapoints, that you can use via TCP. Not sure how the KNX Weinzierl application works

@Dujith If I reset the interface and download the original Weinzierl application, how should I connect to the two interfaces that I’ve on the KNX side from HA?
EG: currently the wind speed form the Meteodata 140 interface is on the GA 0/1/5. This is mapped to a Datapunkt in the CI-KNX IP interface, which I think is exposing the value to the network. How does it work in the Weinzierl scenario?

The datapoint is needed for the Crestron interface. HA does not need that as it can talk to the KNX directly via the tunnel. KNX - Home Assistant

So if that Crestron IP module is just for the Meteodata and you do not have any other devices (like a Crestron screen or other Crestron components) that need to use that, you can try to download the Weinzierl application.