Disable Raspi LEDs with HA OS

Hi, I would like to disable the raspberry PI LEDs. Is there any way to do it?

this does not work:

echo none > /sys/class/leds/led1/trigger
zsh: read-only file system: /sys/class/leds/led1/trigger

If it is currently not possible, I would like to see this being a feature request.
My pi is in my sleeping room and the leds are really annoying.

as ugly as it sounds, a little bit of glue tack does wonders with leds :). I too have the pi in my bedroom and haven’t had an issue since.

Hopefully somebody will provice a real solution :smiley:

As i recalled, we can’t disable the LED for RPI4 as there are no control over it. It’s hardware limitation.

These lines should work on a rapsberry pi 4 with a other OS than Homeassistant OS (found them on the raspi forum mentioned explicitly for the raspi4):

echo 0 > /sys/class/leds/led1/brightness
echo none > /sys/class/leds/led1/trigger

echo 0 > /sys/class/leds/led0/brightness
echo none > /sys/class/leds/led0/trigger

It would be crazy from the raspberry pi organisation if this would be a hardware limitation only on the raspberry pi 4 :o

Yes… you are right. We can turn off all the LED for RPI. My re-collection is wrong…haha… thanks for sharing this info.

Have you been able to turn them off?

Sadly I was not able

Could we turn off the ethernet port LED?

I tried to add the following lines on /mnt/boot/config.txt but NOT working.

# File on /mnt/boot/config.txt
# Disable the ethenret LED
dtparam=eth0_led=4
dtparam=eth1_led=4

Any solution?

It sounds like glue tack time ^^

You can edit the config.txt files at the boot partitions, the path is /boot/config.txt. The setting is still effective after reboot.

Mount your HA OS sd card and insert the following lines.

dtparam=act_led_trigger=none
dtparam=act_led_activelow=off

dtparam=pwr_led_trigger=none
dtparam=pwr_led_activelow=off
1 Like

you mean you have been able to disable the leds by doing that? cool

Thank you, the following code fixed the whole issue and disabled all LEDs :slight_smile:

#Disable RaspberryPi LEDs
# Disable the Activity LED
dtparam=act_led_trigger=none
dtparam=act_led_activelow=off
# Disable the PWR LED
dtparam=pwr_led_trigger=none
dtparam=pwr_led_activelow=off
# Disable ethernet port LEDs
dtparam=eth_led0=4
dtparam=eth_led1=4
1 Like

So I have few RPI4 in my bedroom and for all that work on Raspberry OS I have a script running that will turn off all of the LEDs and only every minute it will blink for the fraction of second - otherwise it would be too bright for me to sleep
now, I have installed also HA on RPi and this is the only LED I am not able to turn off during the night - I think HA OS takes too much control over the RPi
it would be nice to have the ability to do the same with HA installed

What led is still on for you? On my pi with HA OS and the steps mentioned above all LEDs are off.

both: red (power) and green (sdd activities)
for my non-HA raspberries I use simple program to turn both LEDs off during the night (with 1 blink per minute to see if there is still power or so) and for this I use access to:

/sys/class/leds/led*/brightness

but on HA OS there is no access to this (or at least I don’t know how to):

/sys/class/leds/led0/trigger: Read-only file system

as written above, just use the /boot/config.txt file. Then it will work great.
There is no Access to /sys/class on HA OS.