Dishwasher - Candy simply FI - CDI 6015 WiFi

You can use this :slight_smile:

Anyone had any luck in getting the Hoover hwash 500 integrated?

+1 for this, I have tried but dont fully understand the instructions, A video tutorial would be nice.

Hi!

I just tried to use the tool thrugh CMD and Powershell but nothing happens. Could you please tell me how did you do to get the key of the appliance?

First I launch CMD/PowerShell, then I navigate to the /bin folder, then I type the command: ./simplyfi <ip> getkey , but nothing happens. And trying to open the .exe file rigt away gives me several errors one anfter the other…

Many thanks in advance :slight_smile:

On a windows machine you might have to use simplify.exe getkey

I tried with the files from GitHub - MelvinGr/CandySimplyFi-tool: Tool for getting data of your Candy Simply-Fi devices :
on a debian 11.3:

~$ ./simplyfi
./simplyfi: line 7: erreur de syntaxe près du symbole inattendu « newline »
./simplyfi: ligne 7: `<!DOCTYPE html>'

I have a dish washer RDIN 4S622PS-47 and a washing machine OBWS69TWMCE-47
they are both connected to the wifi and are running with the epicure android app.

I’ve just got a Candy H9A2TE-80 Tumble Dryer that uses the hOn app.
It appears that it no longer connects directly to the device itself and instead goes via a cloud service.

You can get some information about the device and what it’s doing by polling some of these API’s, but it appears that it may also be using Amazon MQTT to send events too.

I’ve had a go at trying to find credentials - and it appears its using Salesforce SSO with Amazon Cognito. So there’s a fair bit going on. I wasn’t able to find credentials for the MQTT topics.

I’m fairly green at reverse engineering so if anyone with any knowledge wants to collaborate, please let me know!! :smiley:

I’m gonna keep on it and may start a new thread with anything useful i find.

I have the same problem with oven. It use hOn and I can’t connect with it.

Any advances with hOn devices?

Are you sure that use esp? maybe we can flash a custom firmware.

My current understanding is that the devices communicate via MQTT with an AWS.IOT endpoint (a30f6tqw0oh1x0-ats.iot.eu-west-1.amazonaws.com).
The app then pulls all it’s info from an API.

However, there’s also a “cognito-token” in the headers sent to the server, and in one of the API calls it shows the MQTT topics. But everything i’ve tried to connect to the MQTT server fails.
I’m at a dead end.

Hi all - really impressed with the work that’s gone in to reverse engineering this!

I’ve got three Candy appliances: dishwasher, drier, washing machine. I added the dishwasher and drier fine using this integration, but I can’t seem to add the washing machine. I get the “Failed to detect encryption, check logs” error (log below).

I’ve used Melvin’s CandySimplyFi-tool which gives me a key from the washing machine, but I don’t know where to use it? The config flow doesn’t prompt me for a key, and if I add the MAC address and key in my configuration.yaml like the example earlier in the thread, it also gives an error.

Any ideas what I’m doing wrong?

Traceback (most recent call last): 
File "/config/custom_components/candy/client/__init__.py", line 62, in detect_encryption assert resp_json.get("response") != "BAD REQUEST" 
AssertionError 

During handling of the above exception, another exception occurred: 

Traceback (most recent call last): 
File "/config/custom_components/candy/config_flow.py", line 45, in async_step_user encryption_type, key = await detect_encryption( 
File "/config/custom_components/candy/client/__init__.py", line 69, in detect_encryption async with session.get(url) as resp: 
File "/usr/local/lib/python3.9/site-packages/aiohttp/client.py", line 559, in _request await resp.start(conn) 
File "/usr/local/lib/python3.9/site-packages/aiohttp/client_reqrep.py", line 898, in start message, payload = await protocol.read() # type: ignore[union-attr] 
File "/usr/local/lib/python3.9/site-packages/aiohttp/streams.py", line 616, in read await self._waiter 
aiohttp.client_exceptions.ServerDisconnectedError: Server disconnected

Agree with you andrey1 - the handling of the device state when it’s off could be better. Not sure what to suggest as I see this issue with devices on some of the in-built integrations. Feels wrong that ‘powered off’ goes to state Unavailable and HA then hides the integration thinking the device is dead.

Hi!

I am working in API using only Rest. For now, I get some data

1 Like

This is fantastic. I’ll be following your progress as I’d love hOn integration for my dishwasher.

1 Like

Hi, do you use virtual output with http commands in Loxone?

Hi, first thanks to all of you that are trying to help the community :slight_smile:
I have a Hoover Tumbler dryer, but whenever I try to “talk” to her, she answers “ERR_CONNECTION_REFUSED”. I tryed the “curl” think pointing to its IP, but no answer. I thought it was my network, but now it should be nicely configured, and still…nothing :frowning:

If anyone managed to do this, I would appreciate it :slight_smile:

in binary mode file transfert, it works much better…

shame on me…

I tried to connect my Rosières Dishwasher RDIN 4S622PS-47 (Rosières is a brand of Hoover/Candy and works with the Android app)

http://192.168.92.214/http-read.json?encrypted=0
{"response":"BAD REQUEST"}

So I tried in Encrypted method:

http://192.168.92.214/http-read.json?encrypted=1
186A646C4F1D1000101D122D320C1504415D156867676D43371C001D0A3A0F2A0A4554475D4C486C6E61684B2602020500022B171F0116044652432C554F4A61696E67473E1A05150B2C36081605445641554C4960646D684625041D042E071E0A040147574C544348656B606C4F351802151A36190114435E4A514B49606C656A453A1708070A340A074353475D44406E6D676C4F2B070E4652435947416B666A6E4C351F01031305054353473D5E4E4F6A646C644C2119101A002D1714445641574C4960646D684627110C0B29090311281E114F54465046446C636C644428060B0F1C3E1A0513104A5B4B554F4A61696E67473F0B09350D05044B5F4F545C5645426867676D432901121A360C0A18415D4C554F42696B6D6143240C1E153E0A091D004F54465146446C636C64442313020021020116435E4A504B49606C656A453C001E0B10435E4A514B49606C656A452D0D080D0F34144A5B4B554F4A61696E67471F5F465B4659434568676F6541155C47574C544348656B606C4F145F415D4C564F42696B6D61431B514F5C4E5245426867676D43165D4353475D44406E6D676C4F1C52435E4A504B49606C656A451C524F54465446446C636C64441E5B4554475C4C486C6E61684B1754445641293B29214C486C6E61684B175C534E59455F4760646D1C69621C

Good ! I ask for the key: :+1:

[email protected]:~$ ./simplyfi 192.168.92.214 getkey
## Candy Simply-Fi tool by Melvin Groenendaal ##
error: find_xor_key_list, could not find key

What’s wrong ??? the simplyfi file works on another device… ???

Hi Stephen, can you share the commands you are using in loxone ?

Since this forum is more for Home Assistant I will send you to the Home Automation forum where I have just posted a reply under their Loxone forum.

Could You as well help me?
I put “http://192.168.1.0/http-read.json?encrypted=1 " (in my router i found name ESP_FB37BC for 192.168.1.0” and get the code:
484A44537B3D23043C254B7B1B1A0930412E2D3F7B742C68425931152D052E2D60332F2E2C3D755F6A611A1B7766614D11023C287B7475577D651A1B7766614D110A2F3931033347727209155661624D3A651E287B7475547D72143A7065616663351E327B7475556A7C353D73654A177F22383F356C6D477A72143A706561666722232A7B74755C7872143A70656166603727340A3E755F6A641A1B7766614D11083E2E686C6D477872143A706561667C373A687B7475556A7C353D73654A0B43337D78636C6747645D323E734E273447736C607B7E7549455A313E5823183006657478696C7B6842593115351C1C72117D6C6A7B625A6F41591A780A185F6609657E7875435D6C417277470E544A7E11776C7654445E6C6A034C521B014A7E11776C7654445E6C6A144A4E2E4E52660365625753475E470C3554611B004A7E11757B6F7B625A6F41591A651F013C2D5E226C607B7F64546A7C353D73654A165624272A3C073347727208155661624D3A650D323C2D3C3038034C560E094A7E11776C5753472A68422D
but i have problem with ./simplyfi getkey
While trying to just put IP in HA add’on from HACS i get: “Failed to detect encryption, check logs”