Docker pull "latest" but installed beta

I don’t know why but my latest docker pull installed the 0.85.0dev0 release on my Pi instead of 0.85.1 using latest tag.
I gave a glance to docker hub but I didn’t find any note about this.
What am I doing wrong? i’m not a big expert of docker and code versioning :blush:

Thank You

Maybe you have this problem?

you may have activated the “beta channel” to get notifications of the beta releases. You can check this by going into HassIO and clicking on “system”. If it says “Channel:beta”, then you are on the Beta channel. I think you can go back to the production channel by clicking on “leave beta channel”.

Il looks the same problem but it worked fine up to 0.84.x

I don’t use hassio but a standard image of homeassistant/raspberrypi3-homeassistant

you’re using hassbian?

I’m using a standard Raspbian Stretch lite with HA installed in a docker container.

Even with pulling 0.85.1 instead of latest, the instance reports as 0.85.0dev0. It‘s a naming issue inside HA

I pulled the 0.85.1 specifying the tag and I got the 0.85.1

Well, obviously they fixed it 5 hours ago.

1 Like

that’s not a fix, just a new release. The latest tag for rpi3 will always include betas. not sure why though.

I know, that“s why I don‘t use the latest tag. However, tag 0.85.1 pulled 2 days ago reported as 0.85.0dev0, while the same tag pulled yesterday reports as 0.85.1

So, they obviously fixed the version string and er-published the Image.

Again I downloaded “latest” and I obtained 0.88.0b1

1 Like

Again I downloaded “latest” and got 0.89.0b1
Not so funny…
I cannot wonder why…

Because latest will always pull the latest… I had to stop automatically updating my homeassistant image because of this.

They should make a new tag “latest-stable” and point that one to the latest stable release, so that this does not happen.