Does anyone use the Zillow Zestimate property value integration? Mine seems to have stopped updating and I'm wondering if anyone else is having this issue

My home’s zestimate sensor seems to have stopped updating, even though my home’s zestimate value has changed. The last update was on 11/8. Can anyone that uses it confirm that it is still updating for them?

Nevermind, of course I just checked and it updated for the first time in 10 days 5 minutes after making this post.

1 Like

How did you get an API key? I can’t even figure that part out.

1 Like

I just found this… reading the TOS…

I think I figured it out.
Go Here and hit request at the top right. Fill out the form with information saying you’re “making an app”

Then I got an email today from a support person from the Zillow Group asking for more information on the app you’re making and why you need api access.

Reply to their email with more information on the app you’re making and hopefully they open the API for you.

This is the stage I’m currently at. Just waiting.

Interesting. I was able to make another account yesterday when I was troubleshooting and they sent the api key within minutes. I think the reason mine wasn’t updating is because they were making changes to how it worked. The Zestimate used to change once, maybe twice a day. Now it’s changing a dozen times per day it seems.

How old is your API key? I was reading they used to offer it for really anyone to sign up and access, now you need to apply for it.

Update Don’t say you’re making an app. Say you’re making a website. I got denied access to the API becuase they do not allow mobile app access at this time.

i just installed this and its not coming up at all. Have some errors in the log about string vs float issues.

Can someone provide an example of their sensor from config.yaml? just looking to know if anyone has quotes around any of the values or maybe something else im doing wrong

Thanks

I’m having trouble getting this working as well. They sent me an API key almost immediately (I assume it’s the key, thought they called it a ZWSID). I put it in the configuration.yaml file exactly as in the documentation but it shows up as an orphaned sensor. Of course, ai grabbed the ZPID from the URL as required. No idea why it doesn’t seem to work

It’s something to do with Zillow’s API it seems. My ZWSID from 2019 works fine, but one that I just requested gets the same errors. So it might be that Zillow has changed their API or even disallowed its use in the way we’re trying to use it.

I tried getting a new API and was denied.

Did they cite a reason?

Reading between the lines here, it looks like Zillow has moved their API to a third party called ‘Bridge’. You can no longer get ZWSID api keys for their api. Instead as others have mentioned you have to file a ticket and give them a justification.

I went through this over the last few days and did get an api key (it’s called a server_token). However, I don’t think it works with the Zillow integration because the API endpoints are different.

Here’s how you call the new api:

$ curl -q "https://api.bridgedataoutput.com/api/v2/zestimates?access_token=<your server token>&zpid.in=15243" 2>/dev/null | jq .
{
  "success": true,
  "status": 200,
  "bundle": [
    {
      "id": "3080933",
      "zpid": "15243",
      "address": "IV-8B 241 McCarrey St Anchorage AK 99508",
      "coordinates": [
        -149.791928,
        61.221869
      ],
      "zestimate": null,
      "upper": null,
      "lower": null,
      "date": null,
      "rental": {
        "zestimate": 1100,
        "upper": 1199,
        "lower": 957,
        "date": "2021-02-11T00:00:00.000Z"
      },
      "foreclosureZestimate": null,
      "forecastStandardDeviation": null,
      "zillowUrl": null,
      "url": "api.bridgedataoutput.com/api/v2/zestimates/zestimates/3080933"
    }
  ],
  "total": 1
}

I tried to get an API and was denied. How did you get yours?