Does Google Coral work with Intel NUC on HaOS (for Frigate)?

I’ve seen some topics discussing the use of Google Coral with RPi4s for Frigate etc., but I’m wondering, does anyone know if Home Assistant OS on an Intel NUC (NUC8i3BEH) support Google Coral for Frigate?

1 Like


Do not why it would not

I would think so

Only cause it’s a USB thing so the hard bit mite be finding the USB path I’m just guessing here

Developer uses NUC with coral

1 Like

I run HassOS on a NUC8 as a proxmox VM. The USB TPU has some stability issues that way. On bare metal it should work.

1 Like

PCI tpu has faster inference times
If m.2 or pcie slot available you should purchase one of those tpu versions

With an intel NUC8i5 the only option is USB. The M.2 slot is taken by the SSD.
Inference speed is some 20ms. The problem is “Detection appears to be stuck. Restarting detection process…” errors in the logfile.
Otherwise it does work. Obviously you will need to pass through the USB port to the VM.

I will try to move the frigate software away from HassOS and into it’s own LXC container or something in the future.

But we are getting off-topic, unless the topic starter will be using proxmox as well.

Works fine on mine.

1 Like

I’ve just plugged the Coral USB on my NUC that runs HassOS, changed the frigate configuration and restarted Frigate AddOn. I get the message:

frigate.edgetpu INFO : No EdgeTPU detected.

have you done anything on the NUC on HassOS for the Coral USB to be detected? Am I missing a driver and if so, how would one install it in HassOS?


Nothing but put in the right configuration for Frigate. My understanding is the driver is now included. Did you do a full system restart?

Yes - complete shut down, plugged the Coral USB and restarted.

I run HaOS 2021.6.6 and Frigate 1.13. I just added the detectors as follow:

    type: edgetpu
    device: usb

Do I need to do anything else? Frigate works if I use CPU detectors as it was running like this until now.

In the system Hardware Info I can’t find the Coral USB, at least it is not listed under that name. I can see my Zigbee USB device though. How would the Coral USB show up under this view? Maybe it is not recognised for some reason.

    type: edgetpu

This is what I have.
Maybe drop the device attribute.

I went to lxc and it’s solid now, speed from 32 to 9.8

Ok, I found the issue, although I do not understand why.

I was trying on the two front USB ports as it was a convenient access. But since I could not see the HW, I decided to disconnect my ZWave stick in the back and connect the Coral USB instead (lower port).

After reboot, the Coral USB was immediately detected by Frigate and started to run detection on the dongle. I’ve connected the ZWave stick on the front port and it works well.

Main CPU went from 35% use to 8%. Response is also much faster and streams are smooth!

So for some reason, the Coral USB does not work on the front ports - But now I can confirm that the Coral USB works on a BOXNUC6CAYH (Celeron processor) on HaOS installation.

1 Like

Just to confirm - you didn’t install any of the packages or anything from Coral’s website, correct? I’m also running HassOS and was having trouble installing the packages from the terminal, so thought I was going to be at a loss.

But given your experience, it sounds like you just plugged it in, changed Frigate’s yaml and restarted and then it worked.

That’s right. No installation required on HassOS.


I have a NUCi38BEH with Proxmox and Home Assistant in a VM, and from frigate’s docs optimizations: say:

Intel-based CPUs (<10th Generation) via Quicksync (Hardware/QuickSync – FFmpeg)

    - -hwaccel
    - vaapi
    - -hwaccel_device
    - /dev/dri/renderD128
    - -hwaccel_output_format
    - yuv420p

I have a lot of errors when i try to use these flags, are necessary ?

I’m a little bit confused.

I have for now a camera and I ordered yesterday a google coral usb, because I have tried my others cameras, and cpu get 98%, so need coral.

But about cpu, need these settings or with coral are useless ?

I have a similar issue. I purchased the M.2 version of the Coral EdgeTPU and installed it in a Lenova laptop. I purchased a Mini PCIe to M.2 adapter to make this possible:

HASSOS is running directly on the laptop (no Linux) but I get the message “No EdgeTPU Detected” when running Frigate. I have detectors configured as follows:

    type: edgetpu
    device: pci

Do I need to install drivers for the M.2 version? Anyone been able to get this working or have any ideas?

I am trying the same thing and running into issues. I can’t get the USB accelerator to work. I’m not using a NUC just some generic hardware I put together. I was about to starting trying to install the drivers until I saw this…

make sure you enable IOMMU in proxmox
just add the lines under grub default then update-grub in proxmox shell and reboot
and passthrough your intel gpu