DoorBird: Events not fired

Hi everybody,

I hope that someone can help me out with a little problem.

I have a DoorBird integrated in Home Assistant for a while to show the camera pictures for “Live”, “Last Ring” and “Last Motion”.

Now I tried to create automations to send a notification via Pushover for the events “Motion” and “Ring”. But it seems that the events are not fired at all by Home Assistant. I can fire them manually using the Events page. Here is my configuration and automation file.

doorbird:
  token: !secret doorbird_token
  devices:
    - host: <ip>
      username: <username>
      password: <password>
      name: Front Door
      monitored_conditions:
        - doorbell
        - motion

- id: notify_3
  alias: Front Door Ring
  trigger:
  - platform: event
    event_type: doorbird_front_door_button
  condition: []
  action:
  - service: notify.pushover
    data:
      title: "Haustür"
      message: "Es hat an der Haustür geklingelt."

Any idea?

Thanks in advance.

+1
I have exactly the same problem.
Klaus

In the Doorbird app, go to Administration -> HTTP Calls. You should see the URL that the Doorbird is calling when the doorbell is pressed. You should be able to call this URL from a web browser. If the response is “OK” then the event should have been fired and the automation triggered in HA.

Thanks for the tip. I called the URL and received “OK”. I also received the notification as defined in my automation. But it’s still not working if someone pushed the doorbell.

You are the second report I’ve seen of the Doorbird not calling the configured URLs when an event happens. I would contact Doorbird support and see what they say. Could be an issue on their end with a particular device/firmware.

OK, thanks for your help. I will contact DoorBird support.

I had similar issue (see above). Today I spent half of Sunday to troubleshoot and fix the issue. It seems that eventually it stared working when I removed the user I used for hass integration (not admin) from DoorBird iPhone App. Then restarted Doorbird. Then added the user back with setting the operator permission to on. Saved the config. Restarted Doorbird again… and it started working back! Now both event’s are fired up. Funny I had the correct url in HTTP Call setting of Doorbird App, all the time but anyway it was not working. So try to remove and re-add user and let me know.

Have the same issue… going to try this as soon as I get home! @kstaniek

Have created the user again in doorbird, when I paste the https://blabala.duckdns.org:8123/api/doorbird/looppoort_deurbel_button?token=blabla url in my browser, I get an OK back but my automation does not trigger.

I’ve tested the same thing with the motion sensor HTTP Call and that DOES trigger the automation… so I don’t know what’s going on right now…

@LKrisM did you manage to contact DoorBird support, and did they assist you to resolve this?

I have similar symptoms. No problem injecting an event via the Events dev page, but no luck with a response directly from the Intercom. However in my case, if I call the URL shown in the Admin --> HTTP page in the DoorBird app, https://hassio.local:8123/api/doorbird/front_door_intercom_button?token=xxxxxxxxxx within the same LAN that the DoorBird Intercom and hass.io server are on, then the trigger within HA also works.

I had noted during the initilisation log output this entry:

2019-04-01 09:29:49 INFO (SyncWorker_1) [homeassistant.components.doorbird] Registered for doorbell pushes from DoorBird “Front Door Intercom”. Use the “doorbird_front_door_intercom_button” event for automations.

Which seemed to suggest that all was in order as expected. As I mentioned, I’ve called the URL shown for the DoorBird app and the response is “OK”, and this also successfully triggers the HA integrated event. This suggests the connection break is not in the DoorBird app nor in the HA processing but maybe something to do with the URL the DoorBird intercom is actually expressing.

I should add that if I paste the same WAN URL as @iMartien refers to https:/blabla.duckdns.org:8123/api/doorbird/front_door_intercom_button?token=blabla this also produces an “OK” browser response and triggers my HA automations. It works both if I call it from within my LAN or remotely.

I’m running the most current version of hass.io v0.90.2, and the latest firmware on the DoorBird intercom.

It all seems to confirm that the problem is not with the HA integration per say. Its likely to lie with the HASS_URL the DoorBird Intercom is adding.

@d101au04 Sorry for my very late response.

I didn’t contact the DoorBrid support because I was able to solve my problems before.

I just made a factory reset of my DoorBird and after that the events and notifications works fine.

In the HTTP Calls I have both event and the URL is just with my LAN IP of my HASS.

I have the same issue with my brand new Doorbird. Doesn’t seem to be a Doorbird issue. If i call the URL
http://hass.fritz.box:8123/api/doorbird/doorbird_einfahrt_doorbell?token=token
and get an OK, the event in HA should be fired, right?

Nothing happens…

@Tscherno: Can you please open your Doorbird app go to Administration, HTTPS Calls and verify your HTTPS requests - if they match the names of the events youre listening for in HA?

Hi, i have an indoor A1101 , you can create extra buttons on it (widgets)
i have added a https api call , but seems it doesnt support POST?

how can we add custom tiles on it, to trigger an light for example? how can we do that with an http call ?

webhook only supports POST

edit: nm, found it, i can just create random events with a name, that will create somekind of webhook without POST, that i can use to trigger other thins :slight_smile:

i have the same problem, please help

In doorbird (HTTPS Call) I have this URL and I got an OK

http://192.168.200.179:8123/api/doorbird/doorstation_yyyyyy_ring?token=xxxxxxx

In the automation this does work only wen I fire this event manual:

alias: Telegram Event
  description: ''
  trigger:
  - platform: event
    event_type: doorstation_yyyyyyy
  condition: []
  action:
  - service: script.snapshot_haustuere
    data: {}
  - wait_template: ''
    timeout: 00:00:02
  - service: input_text.set_value
    data:
      entity_id: input_text.zeitstempel_klingel
      value: '{{ now().strftime("%H:%M %d.%m.%Y") }}'
  - service: script.snapshot_haustuere_telegram
    data: {}
  mode: single

Do you have some hints for me?

I am working also on this issue…do you have any ideas for this fix?

Have you made sure the schedules for each event are set under administration?
Under advanced settings for teh doorbell and under motion sensor settings for the motion detection.

I had a missing word (doorbird) in the event type. Correct is

doorbird_doorstation_xxxx_ring