Duck DNS add-on keeps stopping (resolved)

Hi all, my Duck dns add don keeps stopping and therefore locking me out only message get in the log is:
“# INFO: Using main config file /data/workdir/config
ERROR: Lock file ‘/data/workdir/lock’ present, aborting.”

I have made no changes to my Hassio instance for a number of weeks and no issues with my SD card (I have tried 3 separate SD cards all with the identical image (backups)) with the same result

Any pointers as to the meaning of the above error?


I had same isue yesterday. Uninstalled addon, restarted, then installed again with exactly same config. That solved the issue

Ah right will give that a go and see what happens

The plot thickens, I uninstalled the Duck DNS add-on, restarted, then went to reinstall and now I can’t install the add-on no error messages just refuses to install, and to add a little more confusion I still have to login to my Hassio instance with the “HTTPS” prefix

I borrowed the solution from DuckDNS - issues with LetsEncrypt and worked fine for me yesterday…

Well I left the system alone overnight and then this morning it allowed me to re-install the DuckDNS/Lets encrypt add-on without issue, after testing everything seems to be working fine again (must have been some glitch in the matrix lol)


1 Like