Echo Show 15 hybrid Home Assistant Wall Panel

yes, same email

@fnxpt did you also create a „new app submission“ and send the APk to review to Amazon?

Or did you only create a „Live app testing“? That’s what I am trying to do, without to submit the app for review to Amazon.

I also created a new developer account. Same issue with internal server error persisted clicking on the invite link for the tester.

I also noticed, that Amazon checks the package name of the apk and blocks you from using an apk for testing, if an other developer account used the same „apk package name“.

So 2 people can‘t sideload the same apk with the live app testing environment this way.

I also got this when trying to submit the FKB apk

The Home Assistant app for the Amazon app store doesn’t work on the Amazon Show 15?

Correct. The newest APK 2024.1.5 does not work on Amazon Echo 15. Specifically the touch function.

Is there anything changing for the Amazon app store taking the Digital Markets Act into account? Also apple is forced to allow sideloading. Same for Amazon?

1 Like

can u add me to testers? tried to start a Live Testing but keep saying app is already testing by another developer

1 Like

Problem is that Amazon are slowly moving all their devices to FireOS so the apps won’t be compatible.

Download the apk and modify the project name. I use apktool for decompiling the app, rename the project name and convert again to a apk. I tried the Fully Kiosk Browser and HomeAssistant. Neither app works with touch.
Keep in mind, it takes up to 24 hours for the app to be installed on your Amazon device.

1 Like

Does Silk on the echo show 15 have some kind of wierd zoom level set?
I tried building a lovelace-wallpanel with it and when designing the layout on a 1080p laptop screen it looks perfect but on the echo everything is in a different place and way bigger… I thought the echo was 1080p as well? The screen ratios are the same.

In the end I went with absolute postion in the config and then scaled the cards down a bit to make them usable… Maybe I am missing a setting on the echo to put zoom to 100?

(this is what i have got so far):

Thanks

1 Like

ive always found some slight diffrences in scalling when creating on say a windows browser (normally I use firefox) and then viewing it on any Amazon tablet or my Echo Show 15…but a slight adjustment to scale the affected element sorts it pretty quick

2 Likes

@cmaile
About those “no touchscreen” issues or “only remote control” on installed test apps via live app testing, I just found a setting which popped up on one of my testing apps. This setting appears/disappears probably depending on some manifest entry:

1 Like

I have already tried this, but the result remains the same. Still no touch.

@cmaile have you tried editing the manifest xml file and forcing hardware touchscreen to „true“ or adding an entry for „faketouch“?

I read a bit through the Amazon documentation about the how to enable touch.
They work with the normal Android onClick events which the generic Android touchscreen apps should already do.
So my thought was, it’s maybe just a manifest entry we have to set/manipulate correctly to get the touch working in apps on the echo show 15.

I have already some tests waiting to get installed but for some reason my apps stopped appearing on the echo show 15. I got it installed only once and it never worked again since then.
I already created new live testing apps to get new app ids, but still waiting to get anything to pop up…

I can instantly send the live testing app to a fire hd tablet but not to my show 15.
The „refreshing“ of my apps to get those „live app testing“ to the device is brutally annoying…
Why does this take hours or days?
Is there any other way to force the refresh to get the live testing apps appearing instantly?

I am using Apkrenamer with the „-t“ option, then you can edit in the temp folder and then continue to rebuild the apk.

@Crypto90 thanks for the hint. I tried this right now, but i’m not sure if i installed the new created app on the Echo Show 15 or the previous version. To be on the safe side, i will check again tomorrow to see if there is an update in the app store. But somehow I am not optimistic.

Source APK: https://github.com/home-assistant/android/releases/download/2024.1.5/app-minimal-release.apk
These are my new values in the manifest:

    <uses-feature android:name="android.hardware.touchscreen" android:required="false" />
    <uses-feature android:name="android.hardware.faketouch" android:required="true" />

And yes, the rollout process for testing the apps is very slow and therefore a huge shit.

One ray of hope is that there are a few people here who are helping to make the Echo Show 15 a better device (to install Home Assistant). :smiley:

@cmaile
I already tested the update behavior of the live testing app:

If you end the test and start a new test, use the previous test as your template, remove&reupload a new/changed APK and re-set your supported devices or replace the APK (keeps the previous set supported devices ticked) and start the new test appears instantly on the echo show 15.
Just uninstall and install the test app, then you get the new APK which you just started the new test with.
You don’t have to invite yourself again. Just make sure you DO NOT REMOVE YOUR TEST APP FROM THE CLOUD.
This happened to me and I did not found any way to get the “removed from cloud” app back displaying on the echo show 15.

android.hardware.touchscreen = is for hardware touchscreen.
android.hardware.faketouch = is for simulated touches like if you connect a bluetooth mouse to your echo show 15, you get a mouse pointer. The documentations says, that faketouch is for eg. mouse pointer clicks that simulates touches.
I set both to true in all my current tests.

I currently have multiple apk tests running:

  • Fully Kiosk Browser: runs for me with decompiled, renamed and compiled back apk (Apkrenamer), touch still does not work. I have touchscreen and faketouch both set to true.
  • Psplay: I got psplay fully working, I can remote play my PS5 on my echo show 15 with a patched psplay apk. I also renamed the package name with Apkrenamer. The ps5 controller connected via bluetooth is somehow bugged, need more tests.
  • SmartTube Next: Is always crashing for me after Apkrenamer and setting the targetSdkVersion from 26 to 28. 28 is needed for the echo show 15, but smart tube next releases its apks with 26, I don’t know if we just can increase the number in the apktool.xml and recompile it. The resulting installed app is always crashing. Man I want to get rid of those youtube ADS :smiley:
  • Discord: I try to get a Discord app running, to see if video chats are working with it and the build in camera and mic, would be a neat feature. the original mobile apk is working, I could sign in, but also here, no touch. so its hard to navigate. Bluetooth mouse clicks also do not work with the original apk. I tried enabling hardware.touchscreen and faketouch in the manifest but once I recompile and load the app into my echo show 15, its also crashing like the smarttubenext app. I don’t know why.

If we get the touch issues resolved and some app crashes fixed after renaming the package, we would get a pretty solid experience and a neat workaround to get apk’s into the echo show 15 with the live app testing.

Once again, if your app appears once on your show 15, do never remove it from the cloud.
You can end the test and start a new one. uninstall and install, to get the new test apk. this works once the “test is in progress”. which just takes a few minutes to update.

If you wanna make sure, you can edit the version name of the manifest/apktool.xml, which also shows on the store page. so you always know if its your correct version.

@cmaile you can add me somewhere to chat directly with me, would speed up our testing alot and we can share our results and ideas.
Just write me a pm.
I also found out how we can boot the device into a fastboot mode, the echo show 15 just shows the amazon logo, but the micro usb works and is in fastboot mode. But my knowledge with that ends here ^^

@Crypto90 With pleasure but i don’t know how to send a PM via this platform. Where are you from? I’m from Germany.

Click on Cryptos icon/image and yuo should see message

@cmaile I am also from Germany.
If you have discord, add me there, same name as here.