Ecobee AUX mode not responding, is it supported?

I am trying to set my Ecobee3 to AUX mode with a trigger. However it is not working, here is what i tried:

1- Actions > Device > Change HVAC mode. Unfortunately no AUX choice here, so i went to YAML and tried to put in ‘hvac_mode: auxHeatOnly’ from the API, but this rejects it and says:

Message malformed: value must be one of [‘auto’, ‘cool’, ‘dry’, ‘fan_only’, ‘heat’, ‘heat_cool’, ‘off’] for dictionary value @ data[‘hvac_mode’]

so that was a dead end.

2- Actions > Call service > climate.set_aux_heat. the option is there to toggle AUX on, but the ecobee doesnt respond to it.

3- Simply going into Overview, clicking on the ecobee settings, and toggling on AUX manually, it rejects me after a few seconds and toggles it back.

Trying the above automation with HVAC mode Cool or Heat works perfectly, so I know my setup is correct. It’s just the AUX that wont respond, even when manually hitting the toggle. Which leads me to believe this isnt properly supported? Is there a workaround?

I am using HA on QNAP in a container. Thanks


Just encountered the same issue. I think this should be a GitHub issue.

I’m not clear which route is supposed to work, but at the very least the documentation needs to be updated.

opened issue Unable to set aux heat for Ecobee · Issue #64043 · home-assistant/core · GitHub

Thanks for confirming and reporting

I see you worked on fixing the issue.
I’m sorry, I am not fluent with following GitHub change process and I’m a little lost going though it all!
Can you help clarify how to use your fix to enable Aux on ecobee?

I wrote the code to fix it, but it has not been released yet. Someone needs to approve my fix (hopefully before the next release), and you’ll be able to start using it in version 2022.2.0

Hi, any progress on this? It seems like you have all the code ready but it’s stalled now?

Yes, its a bit stalled.

The code is there and working, but I was asked to follow the new code standards for tests. Unfortunately I was struggling to get this working and don’t have much time to work on it right now. Hopefully someone will take over and get this across the finish line.

Any chance this can get polished and implemented? Running into this same issue.

I am also running into the same issue. Does @droberts84 fix just need to be tested?

+1 to making this work. Aux is a legit mode on Ecobee and would be nice to be able to trigger it. My aux heat is hydronic (via wood boiler) and would like to use node red to turn on/off based on outdoor temps throughout the day. No need to turn heat pump on when I’ve got free heat.

@bdraco … I see you were helping on the aforementioned bug report. Could you reopen?

1 Like

I’m trying to read through the PR that got closed Support Ecobee climate Aux Heat on /off by drobtravels · Pull Request #64222 · home-assistant/core · GitHub

I’m not following what changes need to be made to the tests to allow the PR through. Can someone give a level of effort to do that? If someone could point to a good example or two to mimic, maybe I could give it a shot. I have not done any work in this repo before, so this looks a bit time consuming to ramp up on it just to update a handful of small tests in an old PR.

I’m hoping to get the Aux mode working as well.

I opened a new issue referencing the old one.

It looks like this PR should’ve added a toggle for aux heat by “toggling the “Aux heat” toggle in the UI or calling climate.set_aux_heat”, but I’m not seeing that as available on HA container version 2023.11.3. I can see equipment_running: auxHeat1,fan but still aux_heat: "off" and no way to turn it on.

Was messing around with my settings today and spotted:

" Climate: Turn on/off auxiliary heater’ on My ecobee"

I set it up to turn on Aux heat and it worked!

I set it up to turn off Aux heat as a specific time and the whole furnace shut off. Realize I had to tell the Ecobee to go to HVAC mode = heat.
Bingo! it’s now back to my heat pump!

I swear this Aux option wasn’t’ there a few days ago, but it’s been in Smart Things for over a year.

@Wilbour That’s exactly the kind of functionality I’m looking for but am not seeing it anywhere! Did you reload the ecobee integration or anything to get that option to show?

No, I didn’t reload. Is it one of your “States” by chance?

In ecobee

I’d share my Yaml file but I’m not sure how to do that. If I copy paste the script I get an error in this window