Ecovacs component stopped working


#1

Hi,

my ecovacs (deebot slim) component stopped working, i did not change anything linked to this component.

I recently updated to 0.81, so may this is the reason?

I get this error after a reboot

Setup of platform ecovacs is taking longer than 60 seconds. Startup will proceed without waiting any longer.


#2

does anyone have the same issue?


#3

Same issue here.


#4

Do you also get this error in HA?

day is out of range for month
22:28 /usr/local/lib/python3.6/site-packages/sleekxmpp/basexmpp.py (ERROR)


#5

Also have the same issue. Looks like something has broken…

edit: to add more information, it previously was set up and working fine. I get the same error

Setup of platform ecovacs is taking longer than 60 seconds. Startup will proceed without waiting any longer.

and my vacuum (N79s) entity_id no longer shows up in HA


#6

I get the same error


#7

Same error here, I have posted the complete log here:

Regards


#8

Still won’t connect to the ecovas component, running newest version of hass.io 0.81.5


#9

Again no luck with the newest version auf hass.io.

Not working with 0.82


#10

Still broke here too


#11

Same here - had to go back to 0.80.3 :cry:


#12

Is there a way to elevate this in any way? It’s been very broken for a while now, and i know some people have reported it’s an upstream problem… but I don’t see how that can be when v 0.80.3 works fine and newer versions don’t. Something in an HA update broke this for us, and it’d be great if we could get that changed back.


#13

i just responded to @chairstacker in my other thread i started on this, and i rolled back my docker instance to 0.80.3 and it wont connect there any more either. i’m thinking something in the ecovac api has changed with their new updates for more vacuum models. i’m not a coder though so i could be mistaken.


#14

not working in 0.84.5 either, would be awesome if this can be fixed :slight_smile:


#15

Same with me…Ecovacs component not working


#16

Got a Deebot N79S for Christmas. Running HA 0.84.3. No go for me. Would love to have this fixed so I can integrate with HA.


#17

It is working for me now - in .86.4


#18

Hassio with 86.4
I still have the “day of month” problem:

Traceback (most recent call last):
  File "/usr/local/lib/python3.6/site-packages/sleekxmpp/xmlstream/xmlstream.py", line 1492, in _process
    if not self.__read_xml():
  File "/usr/local/lib/python3.6/site-packages/sleekxmpp/xmlstream/xmlstream.py", line 1564, in __read_xml
    self.__spawn_event(xml)
  File "/usr/local/lib/python3.6/site-packages/sleekxmpp/xmlstream/xmlstream.py", line 1632, in __spawn_event
    handler.prerun(stanza_copy)
  File "/usr/local/lib/python3.6/site-packages/sleekxmpp/xmlstream/handler/callback.py", line 64, in prerun
    self.run(payload, True)
  File "/usr/local/lib/python3.6/site-packages/sleekxmpp/xmlstream/handler/callback.py", line 76, in run
    self._pointer(payload)
  File "/usr/local/lib/python3.6/site-packages/sleekxmpp/features/feature_starttls/starttls.py", line 64, in _handle_starttls_proceed
    if self.xmpp.start_tls():
  File "/usr/local/lib/python3.6/site-packages/sleekxmpp/xmlstream/xmlstream.py", line 889, in start_tls
    cert.verify(self._expected_server_name, self._der_cert)
  File "/usr/local/lib/python3.6/site-packages/sleekxmpp/xmlstream/cert.py", line 133, in verify
    not_before, not_after = extract_dates(raw_cert)
  File "/usr/local/lib/python3.6/site-packages/sleekxmpp/xmlstream/cert.py", line 111, in extract_dates
    not_before = datetime.strptime(not_before, '%Y%m%d%H%M%SZ')
  File "/usr/local/lib/python3.6/_strptime.py", line 565, in _strptime_datetime
    tt, fraction = _strptime(data_string, format)
  File "/usr/local/lib/python3.6/_strptime.py", line 528, in _strptime
    datetime_date(year, 1, 1).toordinal() + 1
ValueError: day is out of range for month

#19

I also tried it because of the information above.
I still get the day out error.

Home assistant 0.86.4 on hassio


#20

Anything new on that?