Home Assistant Community

Ecovacs component stopped working

#21

Yep same here, damnit i just got a new one after reading that it is supported

#22

Forgot what post I got this tip from, but you need to downgrade some packages in order for the Ecovacs component to work. I have this built into a package with a bunch of other Ecovacs stuff;

shell_command:
  ecovacs_fix: "pip uninstall -y pyasn1 pyasn1-modules sleekxmpp slixmpp && pip install sleekxmpp==1.3.2 dnspython3==1.15.0"

script:
  ecovacs_fix:
    alias: Fix Ecovacs
    sequence:
    - service: shell_command.ecovacs_fix
    - service: persistent_notification.create
      data:
        title: 'Please Restart HA'
        message: 'To fully fix Ecovacs, please restart Home Assistant.'
#23

@vidvisionify - does this fix work on hassio? Could you share the details of how to execute that script or where to place that logic? E.g. does it go in the scripts yaml file?

Thanks!

#24

You can either put this in your configuration.yaml/scripts.yaml, or use it as a package.

#25

Thanks @vidvisionify. I tried it out on Hassio and it keeps giving me an error with return code: 2

Error running command: `pip uninstall -y pyasn1 pyasn1-modules sleekxmpp slixmpp`, return code: 2

I even tried splitting out the uninstall and install into separate calls (hence why the above error doesn’t show the install part) and it still didn’t work. But that command worked just fine on my Windows box. Not sure why Hassio doesn’t like it, maybe it needs to be executed with elevated permissions?

#26


A pull request is open to fix this issue.
Thanks to @OverloadUT

#27

So nice to see this working again in 0.92.1

Thank you so much @OverloadUT

1 Like
#28

same! that was an awesome fix!

#29

I have a strange issue.

I use emulated hue to control my ecovacs switch with alexa.

So when I say “Alexa, turn on vacuum”. It turns on.

When I say “Alexa, turn off vacuum”. It turns it of, but it says that it is not reachable.

The same thing within the alexa app, but a little different. I can turn it on, but when I turn it on it goes unavailbale and it’s not possible to turn it off. But when when I say. it to alexa again, it will turn it off.

This issue doesn’t appear in homekit (apple).

Alos the homeassisant vacuum switch turn on and off immediately after I tell alexa to controll the vac.

Can someone help. Maybe @petro again?

#30

I have the same issue. There are work arounds, like converting all switches into lights. There’s also a half-ass python solution in this PR. I haven’t implemented any of them yet. The issue is with emulated hue at this point.

1 Like
#31

@petro can count on you. At least I know that it is a known issue now.

Hopefully someone is bale to fix it. Till then I can live with that.

#32

Thanks for posting that link, I started a thread on this 2 days ago. This issue only started to occur for me when updating 92.1 from 91.1.

#33

I don’t believe the issue is related to home assistant. I’m am almost 100% sure there was a change in Alexa that is causing this problem. I had a power outage and the only update that occurred was to Alexa and this problem started. I was at 0.91.4 at the time.