ELK M1 Interface

I’ll give that shot and report back.

Appreciate the help.

That worked perfectly! Thanks again!

1 Like

Recently a new Home Assistant Yellow newb, installed last week. First integration was with my Elk M1 Gold. Significant thanks to all those involved in the development of this integration. Very much appreciative! Working very well, will be doing more as I learn the system.

1 Like

Question: I would like a Aqara Zigbee contact sensor trigger an Elk M1 zone. What would be the best way to accomplish this if possible?

I have looked at the service in the documentation. I’ve setup some “dummy” zones, but when I try to trigger it there’s no indication of the attempt in the Elk M1 logs with Elk RP2.


If anyone has done this or similar trigger action, could you provide me more details? Does the zone need to be a NC or NO zone with EOL resistor to work? Is there a time duration that needs to be applied?

Thank you in advance.

Trying to use output of elk to trigger my doorbell chime. I put a small 12v activated relay at my chime and ran the wires back to Output 7 on my control panel. I made sure Output 7 had a name and the Show checkbox active in ELK RP software. When I reload my integration it does not show up in HA. I can’t use the onboard relay (OUT 3) because I have it set as a reset for my M1XEP triggered by an F-key since it sometimes requires rebooting so I just wired the DC + for it through the relay. I tried naming all the output 7-16 and reloading the integration, but none of them show up. Do I have to use the YAML manual config to use outputs higher than 3?

The ElkM1 Alarm Engine is now available. I suspect that the existing ElkM1 integration will work with it, but I have not seen any integration documentation so I really don’t know. I’m going to start a new discussion for the Alarm Engine where we can have discussions. Please have discussion on the new topic here: ElkM1 Alarm Engine

Elk Products has recently stated strong development comittment to the Elk M1G, it’s not going anywhere and is still considered the Premiere alarm panel by Elk. See beginning of their new training video on the E27. Intro to E27 Alarm Engine.

I appear to have ‘lost’ the alarm_control_panel.elkm1_area_001 entity.
I have panel entities for the other default panels.
However this panel isn’t around.
I have deleted the Integration and loaded it again, but no restoration of the panel for area 1.
I have edited the configuration to manually change the alarm_control_panel.elkm1_area_2, say, to area_1 but the integration UI balks at that.
Oddly the integration is still reporting properly on the change of state of sensors in area_1
Not really much going on in the logs - right now just the ElkM1 heartbeat.

any suggestions on how I may recover the panel? I had it in a lovelace panel before…

Does anybody have updates on the E27 Alarm Engine and Hassio functionality? I’m about ready to purchase a new system and would like to use E27 if it works.

Check this thread. ElkM1 Alarm Engine

Not clear if the existing integration will work.

If there’s some tweaking required I’d be interested in updating the integration. If it’s more than tweaking the path is less clear.

It’s not clear if the protocol docs are available.

ELK M1 Gold connected to HA
for some reason getting this signal sent to HA every 30 seconds with no reason ?

no one touching the code pad and no one moving / triigering PIRs.

thoughts / help appreciated

best, Rick

Elk Keypad Keypad 1 pressed USER_CODE_ENTERED (0)

1:47:20 PM - 2 minutes ago

Meteobridge Wind Cardinal changed to SW

1:46:57 PM - 3 minutes ago

Elk Keypad Keypad 1 pressed USER_CODE_ENTERED (0)

1:46:23 PM - 4 minutes ago

Meteobridge Wind Cardinal changed to SSW

1:45:54 PM - 4 minutes ago

Elk Keypad Keypad 1 pressed USER_CODE_ENTERED (0)

1:45:53 PM - 4 minutes ago

Elk Keypad Keypad 1 pressed USER_CODE_ENTERED (0)

1:45:24 PM - 4 minutes ago

Elk Keypad Keypad 1 pressed USER_CODE_ENTERED (0)

1:44:54 PM -

On the Elk device page you can turn off debug logs. Turn them on until you see one of those messages and take a look at the log or post it here.

Thanks ! Away for this week but t will do on return to site !!

I noticed the same log entries in HA:
Elk Keypad Keypad 1 pressed USER_CODE_ENTERED (0)

I’m not seeing them every 30s, but just a few times this morning.
I turned on elk debug logging and will watch…


Thanks Kevin
I’m still seeing them every minute or so in the Log
And the HA debug is not showing them ??
Thoughts appreciated folks

I need to see the debug log along with the HA log showing the messages.

I am updating and setting up an ~10 year old M1 gold and trying to decide between a M1XEP or C1M1.

I want the cellular comms from the C1M1, but can get that via other means if it won’t play nice with HA.

Does the integration with HA work the same for either?

I know little about the C1M1. The Elk integration requires a TCP internet connection between HA and the Elk. If that’s possible with the C1M1 then it should work.

Okay cool. I’m pretty sure it will allow for a TCP.

I’m going to order the C1M1, and report back when I can get it installed in a couple/few weeks.

Reading the tech note it does sound promising. There is mention of strong encryption. That may cause problems. It’s unclear without more detail. The integration does support TLS which is storing.

If you find any other tech notes I’ll take a look at them.