Emulated_hue and Google Home - not able to use port 80

Just opened a new topic so it is a bit cleaner.

I can’t configure port 80 for the emulated_hue on a PI as that is a privileged port. So I can’t get it to work.

There is a PR https://github.com/home-assistant/home-assistant/issues/4737 for this topic. but no solution yet.

I was just wondering if somebody here has run into the same issue and if you were able to work around it.

Looks like some guys on Reddit got it figured out.

Above my head though.

not that difficult though but it depends how you installed HASS … the post refers to a virtuealenv but as I’m not using that I needed

sudo setcap ‘cap_net_bind_service=+ep’ /usr/bin/python3.4

than configure with port 80 and… now it works !!!

1 Like

Does someone know if you can change color of your lights with this? I tried to tell it to change the color of my lifx lights but I get “i can’t do that yet.”

Is is normal that I can no longer reach the emulated hue hub via:

once I’ve added to the config yaml?
type: google_home
listen_port: 80

I can’t seem to get the Home to find anything from the emulated hue hub.

You changed the port to 80 so you should try http://:80/description.xml

Thanks to Discourse for showing me the list of threads and this thread matches what I was about to start, I got Home Assistant working with port 80 exposed.

Although not applicable to Alexa, shouldn’t the note be added for Google Home in Emulated Hue Bridge component?