Emulated hue does not report to alexa that state changed

I just installed the emulated hue configuration in my yaml file and have it working. I am just learning home assistant and only have 1 switch at this time. I wanted to make sure I could get this working before investing a lot in this system. When I tell Alexa to turn on my switch it actually turns it on but reports back to me that’s its unresponsive to check network connections. I looked at the API page and this is what it shows when on {"2": {"modelid": "HASS123", "name": "Fire Place", "state": {"bri": 255, "on": true, "reachable": true}, "swversion": "123", "type": "Dimmable light", "uniqueid": "switch.ge_14288_duplex_receptacle_switch"}}. If I turn it off the 255 after “bri” changes to 0. Is there anything I can add to the configuration file so Alexa will know when the switch actually responded?

I get this occasionally, it’s nothing to worry about unless it’s happening every time? It’s just that sometimes it takes a bit too long for the message to get passed back that the task is completed.

It happens every time I tell Alexa to turn it on but I don’t get the error when I tell her to turn it off

How quickly does the actual switch react to the turn on? Can you change the frequency at which homeassistant polls the switch for its status?

I just noticed the On state is changing in the api file from True to False so not sure why Alexa is not seeing it

The switch is actually turning on a couple seconds before Alexa says it didn’t respond. The really isn’t any delay in it turning one after I tell it to. I am new to this where do you change the polling settings

But how quickly is that updating on the homeassistant interface? (ie how quickly does homeassistant know that the light is on, so it can feed it back to Alex)

Dunno, depends on the type of switch and how it’s integrated.

I have version 0.84.2 with hassio front end. When I tell it to turn on via Alexa it happens immediately and the switch icon on the hassio overview screen also changes to on at the same time then about 2 seconds later Alexa responds that it isn’t responding check its network connection and power supply. The switch is a GE 14288 duplex receptacle. The only place I see where I can change anything for the switch is if I go to the Configuration tab and click on Customization tab. I can then choose the entity but I don’t see polling, all I see that looks even like polling is max baud rate (JSON formatted) set to 40000.

Not sure if this has anything to do with it but I had to set the listen port to 80 in the emulated hue configuration. I could not get alexa to detect any devices when it was set to 8300.

I don’t think the port will make a difference tbh, I take it that’s a Zwave switch? Can the polling interval be increased in the Zwave settings?

Yes it is a Z Waves switch. I have not been able to find where I can change the polling. From reading on the home assistant website it appears that hard wired switches automatically report with no need to change the polling. I looked in the log and everything shows to happen in less than a second. From the request to turn it on to when it is reported to be on. It appears that Alexa is just not seeing it. I don’t know of any way to check and see what Alexa is receiving. There is a listen port setup in the emulated hue configuration should there also be a speak or report port setup??

No idea I’m afraid. I’m only speaking from my personal experience, and for me it is quite rare that this happens and is usually when I switch a Hue bulb which takes a couple of seconds to update it’s state, so by the time the message has been passed back Alexa is already telling me that the device isn’t responding.

As I say it’s not very often so I haven’t looked in to fixing it, was just thinking out loud with ideas for you but it looks like we’ve exhausted all the options I can think of at this time of the morning, sorry :slight_smile:

Thanks for trying to help
When I try to pair the hue bridge using the Alex app I can only get it to discover my switch if I choose the old style hue hub(Round). If I choose the new style hub(square) it says no bridge found. Could this be whats causing my issue??


Did you ever get this to work out?

I am currently in the SAME spot as you were, albeit with a Sonoff Basic switch that is flashed with ESPHome.

I had to use the old style round hub in the Alexa app in order to find the devices, as you did, but they work every time. My ONLY annoyance is when the light comes ON, she sputters out that bullshit about the device not being responsive. Still turns on fine, then off fine with no complaining on the OFF.

Please let me know if you ever found a way around this. I am now on Hass.io (Rpi3+) version 0.93.2.


No I never did. Got busy and have not even tried to get it working.

This is a bug in the current version. 0.93.2 0.94.0 might have the update to fix it.

One can only hope :slight_smile:

the fix works, people are using it. I’m using it. It’s just not in the official build.

Is the fix for hass.io on Rpi3+? If so, how do I access the file to change that line of code? I only see a json file in my config and it is not the same as what is shown in the fix.

the fix is in the component. The component is broken at the moment, it has nothing to do with this thread or the information in this thread. It’s just dumb luck that it has the same symptoms as this thread. If you take the code changes from this PR and make it into a custom component, you’ll have the fix.