Emulated Hue not found by Alexa

Not sure if other had this issue so posting and hope it helps

I am now able to consistently pair emulated Hue devices to Alexa using below.
This required NO config Kung Fu or trickery.

1. Verify descriptor file is present at http://<HA IP Address>:8300/description.xml (means Emulated Hue running)

2. Restart HA from Developer Tools (this stops Hue)

3. Wait for descriptor file to be available at http://<HA IP Address>:8300/description.xml (means Hue restarted)

4. immediately attempt Alexa Device Discovery when descriptor file loads (when Hue starts)

It seems that Alexa is only able to discover devices when emulated hue is first started
Devices may show as “offline” if you run Alexa discovery again, but they still work without error

I have tried this but it doesn’t work.

This is what I have in my configuration.yaml…

  type: alexa
  expose_by_default: true
    - switch
    - light

Alexa still says no smart devices is found. I am using Echo Dot.

Never mind. It works after retry few more times.

So I confirmed that I am getting the descriptor but my alexa can’t find my emulated hue even when detecting as soon as the descriptor is served.

Hi @masterkenobi, how did you get this working?

Just try and do it as instructed, as soon as /description.xml becomes available? I can’t get this to work! Any help would be appreciated!

Yes. Once the page loads, immediately press the Discover button in the Alexa app. If possible, press right before the /description.xml page loads. Sometimes you need to try few times before it is successful.

Thanks! This worked for me.
…but why?

Hi All, by way of update. I have since discovered that you must have at least one genuine amazon echo/dot in your setup, then this will work.

If you’re just running on an AlexaPi, it won’t work, because the AVS does not have a component detection feature built in.

Can anyone confirm if this method still work? Even killing the HASS process and restarting doesn’t work for me. I even tried removing one of the existing devices in the Alexa app, but cannot rediscover anything.

Can any confirm if this method still works? I tried repeatedly with no success.

If you’re set up right it just works at any time, none of this restarting and quickly trying to discover it rubbish.

Perhaps those that found they needed to do that have something else that loads just after and breaks it.

@Bobby_Nobble may be correct here. See my other thread here for the solution that worked for me.

I don’t mean to dig up an old thread but just want to put this here incase it helps anyone down the track.
I had my Raspberry pi3 plugged in with Ethernet to an old router directly hooked into my main modem over Ethernet, Decided to retire the router and use a D-link Ethernet switcher instead.

A few weeks later noticed in Alexa devices all said “Offline” but everything turned off and on as expected but nothing new added could be found, After trying all tips in this thread I gave up and just left it… Then It came to me that maybe it was the switcher!. So I plugged the Pi into the old router again and low and behold everything is appearing online :slight_smile:.

So I can confirm (on my end at least) that it was a network issue of some sort.

1 Like

I would say it’s better here than as a new thread without the historical info for reference :slight_smile:

A few people with the same problem have eventually ‘admitted’ to changing routers ‘around the time it happened’ but for some reason won’t see that that may be the issue so thank you for sharing.

Networks seem so simple but are really much more of a black art the HA ever is. I’ve come to the conclusion, unless you really know what you’re doing, that it is often a matter of luck if everything works as it should out of the box.

Is this thread/fix relevant?