Emulated Hue not seen by Amazon Echo

I have just setup my Raspberry Pi 2 with latest stretch and Home Assistant in virtual enviroment.
Got my limitlessLED lights working nicely as well.
I am now trying to get emulated_hue working but no luck.
Http://m.y.i.p:8300/description.xml works nicely as does http://m.y.i.p:8300/api/pi/lights
When I do a discover from the Echo, 2nd gen new today, it gets the description several times in quick sucession, never asks for the lights and says nothing found.
Oh dear!

Said many times before, doesn’t work with just the new Echos on your network, get yourself a Dot too and all will be fine.

Thanks Bobby, now found the other posts. Project was to connect 1x echo to an existing limitlessLED lamp using spare RPi. Has been a very interesting 3 days project learned a lot.

From the breaking change of 0.61.1. I think emulated Hue doesn’t work anymore. The new way to expose and customize alexa

Customizations for how entities are exposed to Alexa are no longer set via customize. Instead they are set via the configuration of the cloud component:
name: ‘Name for Alexa’
description: ‘Description for Alexa’
display_categories: ‘LIGHT’

‘emulated_hue’ and ‘cloud’ are completely different things, nothing’s changed.

I have now resolved my problem, emulated_hue is now working for me, using latest Raspberry Pi, Echo 2nd gen and HA 0.61.1.
I added listen_port: 80 to emulated_hue: as suggested for google home.
The setcap as suggested gave an error on my RPi because it cannot be done on links however i followed the link thru and the following worked for me on my RPi
sudo setcap ‘cap_net_bind_service=+ep’ /usr/bin/python3.5

As I’m only interested in a couple of lamps i can now ignore the complications of Alexa Skills.

I used tcpdump to resolve this. I noted that the Echo would always ask for and get http://m.y.i.p:3200/description.xml but never move on past this, but try a few times.After the change the conversation was much longer. Suspect Echo no longer likes non standard web ports.

Interesting, Amazon themselves have said the new Echos don’t support the original api anymore which is what emulated_hue uses, namely the Echo v2, Echo Plus and Echo Show.

Wonder why it works for you, should be more to it than just changing a listening port.

The Dot and Echo v1 are unaffected.

Hopefully somebody else in trouble will give it a go and we will find out.
Have only been playing with the Echo/HA for a few days but wanted to voice control the lamps I have had for a few years.

(bored retired product support engineer)

I wanted to upgrade my dots (v2) to version 3.

After pulling the plug of the last v2 emulated hue stopped working.

So this means if I want to use emulated hue I have to leave one echo dot v2?
Will the emulated hue component be updated to work with the new echos too?

1 Yes and 2 No. Nothing stopping you just leaving a v2 in a cupboard on mute.

1 Like

Just wanted to let you know that for some mysterious reason - after just adding an echo dot v2 to my network I had to switch the emulated hue from port 8300 to 80. I did not remove the echo dot from the network, just added a new echo dot v2 and that changed everything. Therefore I would like to suggest to change the documentation to always include the “listen_port: 80” - not only for google but in general !!!

Nope, it’s something weird at your end, sorry!

First, yes, the new amazon echo was broken, I am getting a new one (replacement) next week. And second:
I think I found a different issue. Having an api_password in the http config might cause trouble with the emulated hue?

Sorry, that was not it. Can also be something weird going on now with the discovery component and my Nanoleaf Aurora Light Panels - still need to investigate a little further.

1 Like

Hey - could somebody please confirm that the emulated hue is still working without any problems even with the latest echo dot v2 “Device software version” = 628537320 - with that version alexa now supports voice to account matching so the system knows who is talking and can e.g. play his/her music. Due to my mysterious issues in the past I am trying to eliminate potential problems - and things got really bad today after I activated the voice registration.

I used that change and switched also to port 80 - and it works for me as well, with the latest firmware on my echos.

hmm, i still cant get my Echo (2nd gen) to recognize the emulated hue.
Ive done:

  • sudo setcap ‘cap_net_bind_service=+ep’ /usr/bin/python3.5

  • changed listen_port to 80

  • restarted home assistant

But still nothing comes up in the Alexa app when i tell it to discover devices.

My config.yaml looks like this:

type: alexa
listen_port: 80
expose_by_default: true
- script

customize.yaml looks like:
friendly_name: ‘Dim lamp and turn off after 5 seconds’
emulated_hue: true
emulated_hue_name: ‘Goodnight’

Any ideas what I can try next?

I had the same problem, but got it solved by changing ‘listen_port’ to 80 and rebooting HA.
Now Alexa (Echo Dot v3) finds everything.

What do I have to say to get scripts working?

weird. As you can see above, i changed my port to 80 also but it didnt work. Im just using the free 1 mo cloud service for now for alexa until i can figure out emulated hue

What does http://ip.adr:80/api/pi/lights give you?