Enable device (PHONE) tracking after setting up HA app (Android)

Dear all,

I have setup the HA companion app and during setup didn’t grant location access. I try to activate this after the fact but i can’t seem to get this done. I tried numerous things amongst which uninstall and reinstall (incl clear cache and data) but it doesn’t allow me to set this up when reinstalling.

I followed various google and community posts but no luck so far. My guess is i need to do some YAML config that’s fine but i can’t seem to figure out.

I have enabled the location services and sensors in the companion app.

I am obviously missing something any nudge is appreciated

The main goal i am trying to achieve is to us my phone and other people in the household for presence sensing

Here is a more on the companion app
Home Assistant Companion Docs | Home Assistant Companion Docs (home-assistant.io)

You might (probably) also need to grant location access to the HA app, this is done in android settings and depending on the phone/version this differs
Choose which apps use your Android phone’s location - Google Account Help

Mine mobile tracing is working just fine and I didn’t do any yaml config. Did you set up your zones in ha?

Done that (Samsung S21), didn’t help, worked my way through the HA companion doc but no luck. I can’t select a phone with a person in the HA browser either so my guess is the deep integration that is reffered to is not setup in my case.

Hence my Yaml remark am i wrong here?

Zones are optional i don’t work with zones (yet) i enabled the other 3 location settings in the companion app

Well I have defined zone home in ha. At least you need a home zone. I enabled geolocation sensor in companion app and my mob is detected home/away. So I can run automatons ie turn off lights when I’m away.

Location zone enabled, but the device tracker entity doesn’t show up ( i rebooted the HA device) still no luck

I went to check it on my ha. I have an entity “sensor_my_mobile_geocoded_location” that shows my current location.

Recap: you have allowed HA app location access, your HA app connects properly to the HA server and you see no device_tracker entries? Does anything show in the integrations → mobile app ?

EDIT: i.e. if you go to your mobile app > entity > open them …it should show something with devide_tracker.[phone] and this should contain the lat/lon

And…when you possibly re-logged in…there may be more devices to the same phone and only one will show correct data

I am running an android phone, but will check your suggestions’

There is no integration showing saying mobile app in my dashboard (as in your screen shot), i do have the companion app installed connects to the HA server.

default config is on in yaml. So i still think i am missing someting in the Yaml file.

mobile_app:
I have it, dont remember anymore why.

Added restarted but no luck

So when setting up the companion app i DENIED location access

I tried removing the app and do a fresh install (after removing data an cache), but it will not ask me the location permision again so that isn’t helping.

Judging by the text in the image some stuff get’s setup for you when you do not deny location permission. So this has to be somewhere but i struggle to find it

Not seen this before, I had a similar situation a few months ago with SamA51 but after I added the Android location permissions and updated the HA sensors then all started working

So this seems to fix it:

  • On your phone, go to app management
  • Force stop
  • Empty Cache and data
  • Toggle location permissions from on to off and on again
  • Start the app on your phone then it will (re)guide you through the wizard and you can enable tracking
1 Like

Next time you get stuck don’t forget we have troubleshooting steps on the docs. Surprised no one mentioned them here

I did go through the steps in the documentation but that didn’t help, so i ended up asking a question here. If The docs don’t work the formu doesn’t show a post like my problem and google ends up empty handed. Then i ask a question in here.

I have another one pending on Home Connect no answer yet (the docs didn’t help there either)