Energy dashboard display problem

For some reason the energy dashboard display is now all scrunched up to the left of the screen, with half the screen on the right just white space. Seems to have happened as a consequence of the recent update I think.

I can’t see any way to get this dashboard back to the old full screen display that it used to show. If anyone has any ideas as to how to do this I’d be grateful, as it’s a dashboard I use regularly.

You are likely using lovelace-card-mod.

We have to wait for it to be updated. There is a 3rd party issue for it - this is not a core (HA) issue.

Thanks, never heard of card-mod, though. Is this something that I can configure to fix the display issue?

Edited to show the issue - the standard Energy Dashboard used to fill the screen with no white space to the right:

Same Problem here…

Core 2023.11.0
Frontend 20231030.1

I wonder, do all users observing the glitch have card-mod installed?

card-mod has been fixed, and the energy panel is working properly again

No idea what card-mod is, everything seems to be up to date on my HA install. The Energy Dashboard is still only covering the left half of the display.

see this repo, and the fix for the mentioned problem: Release Fix for Home Assistant 2023.11 · thomasloven/lovelace-card-mod · GitHub

are you sure you doing have that installed? If you use HACS, please check and search for it in the resources list

Hi, I’m newbie. how to use this fix?

I noticed the same behave after the update to 2023.11.
also I do have Card-Mod installed… but just refreshing the page helped me actually and the energy dashboard was shown normal afterwards.

OK, I haven’t tried it again then to see, if the issue reoccured…

if you have card mod installed, update to the latest version.
That should fix the issue.


Just checked my Energy Dashboard again.
The Card-Mod Fix did not change the issue, and it is comming back again.
Reloading the Screen does work, but as soon as you open the Energy Dashboard again, it looks the same and takes only half of your screen.

You need to do a hard refresh after updating card-mod. If you are using Chrome press F12 then long click the refresh and three options will appear - select the bottom one (empty cache and hard reload)

Screenshot 2023-11-03 082724

1 Like

yes, thank you.
I figured it out that this was a chaching issue… this time, it was a bit harder to reload the cache :smiley:

Indeed clear cache did the trick

Thanks, I had no idea that card-mod was installed, I don’t use it but did find it and just deleted it. Combined with clearing my browser cache getting rid of this has fixed the problem.

Thanks to everyone that helped, much appreciated.

1 Like