Error adding SmartThings Integration

I’m new to HA. I tried to add the SmartThings integration and got this error: “Config flow could not be loaded: undefined”. I previously had added but then removed the integration, and I assume something went wrong in the removal. In any event, I’m stuck now trying to add it again. I searched the forum but could not find a relevant thread. Any thoughts on how to resolve this problem would be greatly appreciated. Thanks.

1 Like

I am having the same issue. Please let me know if you were able to resolve this.

This solution from another thread worked for me:

Quote 1:

 After trying the steps above and reaching the same error I found a file that was leftover after removing the earlier instance: “*config/.storage/smartthings*” (note that the storage folder is hidden). After deleting this smartthings file, I was able to get past this error and re-establish a connection to SmartThings. Hope this helps.

From <> 

Quote 2:
Here’s what I did:
1. Go to Supervisor->Add-on store
2. Search for Terminal & SSH and install it
3. Enable “Show in sidebar”
4. Click “Start”
5. Open up the terminal in the sidebar
6. Enter “cd config/.storage”
7. Enter “ls -la” to confirm that there’s a smartthings file in the list
8. Enter “rm smartthings” to delete the file
When I tried to set up the smartthings integration after that, I didn’t get the “Config flow could not be loaded” error.

From <>