Error during setup of component Zwave (Hassbian)

I ran the Hassbian zwave script, added user homeassistant to dialout group, rebooted, changed configuration.yaml, and restarted… following the directions here

home-assistant.log shows

Traceback (most recent call last):
  File "/srv/homeassistant/lib/python3.4/site-packages/homeassistant/", line 192, in _async_setup_component
    None, component.setup, hass, processed_config)
  File "/usr/lib/python3.4/asyncio/", line 388, in __iter__
    yield self  # This tells Task to wait for completion.
  File "/usr/lib/python3.4/asyncio/", line 286, in _wakeup
    value = future.result()
  File "/usr/lib/python3.4/asyncio/", line 277, in result
    raise self._exception
  File "/usr/lib/python3.4/concurrent/futures/", line 54, in run
    result = self.fn(*self.args, **self.kwargs)
  File "/srv/homeassistant/lib/python3.4/site-packages/homeassistant/components/zwave/", line 253, in setup
    CONF_CONFIG_PATH, default_zwave_config_path))
  File "/srv/homeassistant/lib/python3.4/site-packages/openzwave-", line 82, in __init__
    libopenzwave.PyOptions.__init__(self, config_path=config_path, user_path=user_path, cmd_line=cmd_line)
  File "src-lib/libopenzwave/libopenzwave.pyx", line 677, in libopenzwave.PyOptions.__init__ (src-lib/libopenzwave/libopenzwave.cpp:10141)
libopenzwave.LibZWaveException: "LibOpenZwave Generic Exception : Can't find config directory /srv/homeassistant/lib/python3.4/site-packages/config

I found one thread with these errors and the problem involved /dev/ttyACM0 not showing up, but mine shows up fine with
ls /dev/ttyACM*

For the hassbian install, you typically would have to only run the Open Zwave install script (which takes awhile). You should not have to manipulate the dialout group. You would typically only need three lines in your config to make this work:

  usb_path: /dev/ttyACM0
  config_path: /srv/homeassistant/lib/python3.4/site-packages/libopenzwave-0.3.2-py3.4-linux-armv7l.egg/config

Check to make sure that the config_path directory exists by using “cd” on the commandline. Your config_path could be different, so drill down to see if you can get to the config directory like the path above. If yes, try those three lines in your config. If no, replace it with whatever path you can drill down to that ends in /config…

Again, I am just guessing here, but that is the path that I used for my last hassbian install…

1 Like

I added
config_path: /srv/homeassistant/src/python-openzwave/openzwave/config
and now there are no errors in the home-assistant.log
I used that path based on the info in this thread, but I’m not sure it’s the right solution in this case. Cannot open Control Panel (ozwcp) Cannot find a path to the configuration files

I don’t have any zwave devices, yet, but I’m guessing that no errors means it’s setup correctly now and once I get that “Cannot open Control Panel (ozwcp)” from the thread above solved I can take the next step of deciding which motion sensor to buy :slight_smile:

The closest folder I have to your example is
but it doesn’t contain anything named config. In that aforementioned thread I mentioned which folders and links do exist if that helps.

Oh, just found this on the States page
Aeotec ZW090 Z-Stick Gen5 US … Ready
Thanks, BendedArrow!

For openzwave control panel, it is a different folder. try this:

cd /srv/homeassistant/src/open-zwave-control-panel/
sudo ./ozwcp -p 8888

The installer script has been causing an error in some installations (e.g. Hassbian) where it places a symbolic link to a folder that doesn’t exist and ozwcp won’t launch until you point that config link to the right place. Cannot open Control Panel (ozwcp) Cannot find a path to the configuration files

Got it fixed. The community here is great as I’ve found quite a few answers by searching the forum and in this case getting my specific issue answered. Thanks again for the help.

1 Like