Error in upgrading to ESPHome 2021.12.1

Trying to upgrade from 2021.12.0 to 2121.12.1, I get the following error:

21-12-19 13:50:12 ERROR (MainThread) [] Unhandled exception: '15ef4d2f_esphome'
Traceback (most recent call last):
  File "/usr/src/supervisor/supervisor/jobs/", line 106, in wrapper
    return await self._method(*args, **kwargs)
  File "/usr/src/supervisor/supervisor/addons/", line 265, in update
    store =[slug]
KeyError: '15ef4d2f_esphome'

Any others having this issue, or does anyone have an idea as to root cause?

Running on RPi 4 - standard install

Not sure of root cause - but a hint from another thread suggested I drill down to ESPHome in the add-on store and try the update from there. Lo and behold it worked… Go figure.

Hi zoogara, we tried this the other day as we had the same problem but we could only see the official add-ons and not any of the Home Assistant Community Add-ons. Glad this worked for you :slightly_smiling_face:

If your reading this and can’t see the Home Assistant Community Add-ons I posted how I resolved this problem on the link below.

1 Like