Error mobile_app not loaded

Thanks, had the same problem right now. default_config: was missing in my config.

Same issue here, anyone who has a solution?

Good grief!
Either add mobile_app or default_config to your config… or read the docs.

Nice going buddy, would be so much nicer to just point out where we can find the docs than acting condescending… :roll_eyes:

4 Likes

Would be even better if you read the post above yours!

1 Like

For the benefit of anyone else finding this post in the future. Please add default_config: to your configuration.yaml file. This enables multiple components.

The migration guide can be found at: https://companion.home-assistant.io/getting_started/migration

Tom,

I was looking at the doc for default_config: to see what it changes, I was not familiar with that entry. Is it save to replace all the mentioned entries in my config file by this one? Any gotchas?

Sure it’s safe. As long as you don’t expect the devs to change the included entries in the default config in future.

If you don’'t think this is a good idea then keep what you have and just add mobile_app:

my system hates mobile_app

Component error: mobile_app - Requirements for mobile_app not found: [‘PyNaCl==1.3.0’].

Unable to install package PyNaCl==1.3.0: WARNING: The directory '/.cache/pip/http' or its parent directory is not owned by the current user and the cache has been disabled. Please check the permissions and owner of that directory. If executing pip with sudo, you may want sudo's -H flag.
WARNING: The directory '/.cache/pip' or its parent directory is not owned by the current user and caching wheels has been disabled. check the permissions and owner of that directory. If executing pip with sudo, you may want sudo's -H flag.
  WARNING: Building wheel for PyNaCl failed: [Errno 13] Permission denied: '/.cache'
ERROR: Could not build wheels for PyNaCl which use PEP 517 and cannot be installed directly

Agree with tom_I. If you’re happy with what default_config does go for it. If you want a super locked down system, load the individual components but note they can be updated and call others

I’ve been a Home Assistant user for about a year now. I came from the Vera platform and Lua programming. HA and Python were very foreign
to me at first and I reached out to the forums on several occasions. More than once I got the dreaded RTFM response. Great. Maybe the answer is in there but it may take hours or days to find. This forum should be about helping folks learn, not bashing someone who can’t find the answer elsewhere. Eventually my skills improved and I felt like I could help people who were struggling like I was a year ago. It was nice to pay it forward and actually help someone.

As new platforms and procedures roll out there will certainly be some who are still new and at a total loss as to how to solve the issue at hand. They reach out here and get told to RTFM! Well, I’m sorry, but not everyone is as smart as you and EVERYONE needs a little help sometimes. If your BEST answer is RTFM then I humbly suggest that you STFU and simply move on to the next post.

4 Likes

Hello guys,

I RTFM. I did add mobile_app (not default_config because the components behind are configured for my needs individually), the discovery line was already in my configuration.yaml
As it was not working

 ERROR (MainThread) [homeassistant.setup] Unable to set up dependencies of mobile_app. Setup failed for dependencies: cloud

Despite what is written, the cloud component seems mandatory, at least in my configuration.
So I added the cloud line in the configuration.yaml, without success:

INFO (SyncWorker_6) [homeassistant.loader] Loaded cloud from homeassistant.components.cloud
INFO (SyncWorker_8) [homeassistant.loader] Loaded mobile_app from homeassistant.components.mobile_app
ERROR (MainThread) [homeassistant.setup] Setup failed for cloud: Unable to import component
ERROR (MainThread) [homeassistant.setup] Unable to set up dependencies of mobile_app. Setup failed for dependencies: cloud
ERROR (MainThread) [homeassistant.setup] Setup failed for mobile_app: Could not set up all dependencies.

Working in IT for 25 years, I tried to increase the logger level and there is basically nothing more in the log:

ERROR (MainThread) [homeassistant.setup] Setup failed for cloud: Unable to import component
DEBUG (MainThread) [homeassistant.core] Bus:Handling <Event call_service[L]: domain=persistent_notification, service=create, service_data=title=Invalid config, message=The following components and platforms could not be set up:

 - cloud

Please check your config., notification_id=invalid_config>
DEBUG (MainThread) [homeassistant.core] Bus:Handling <Event state_changed[L]: entity_id=persistent_notification.invalid_config, old_state=None, new_state=<state persistent_notification.invalid_config=notifying; title=Invalid config, message=The following components and platforms could not be set up:

 - cloud

Please check your config. @ 2019-11-27T16:01:33.181916+01:00>>
ERROR (MainThread) [homeassistant.setup] Unable to set up dependencies of mobile_app. Setup failed for dependencies: cloud
INFO (SyncWorker_6) [homeassistant.loader] Loaded google_translate from homeassistant.components.google_translate
ERROR (MainThread) [homeassistant.setup] Setup failed for mobile_app: Could not set up all dependencies.
DEBUG (MainThread) [homeassistant.core] Bus:Handling <Event call_service[L]: domain=persistent_notification, service=create, service_data=title=Invalid config, message=The following components and platforms could not be set up:

 - cloud
 - [mobile-app](https://home-assistant.io/integrations/mobile_app/)

Please check your config., notification_id=invalid_config>

And, for good measure, here is part of my configuration.yaml, nothing fancy here:


homeassistant:
  # Customization file
  customize: !include customize.yaml
#  auth_providers:
#   - type: homeassistant
#   - type: legacy_api_password
#     api_password: !secret http_password

logger:
  default: notset

# MQTT Broker
mqtt:
  broker: localhost
  username: mqtt_user
  password: !secret mqtt_password

system_health:

# Enable the auth component
#auth:

recorder:
  purge_keep_days: 5

# Enables the frontend
frontend:
  themes: !include_dir_merge_named themes/
  javascript_version: latest

homekit:

# Enables configuration UI
config:

# iOS alerts
ios:

# Discover some devices automatically
discovery:

# Cloud
cloud:

# Mobile application
mobile_app:
1 Like

Sorry I can’t help as I have the exact same issue as you have described. Despite using default_config: and/or mobile_app: I simply cannot get mobile_app to load.

ERROR (MainThread) [homeassistant.setup] Setup failed for mobile_app: Could not set up all dependencies.

In fact, my notifications area reports the following.

Invalid config

The following components and platforms could not be set up:

  • cloud
  • mobile-app
  • default-config

Please check your config.

I guess your instance may have dependency problems, are you by any chance running directly on top of python?

I think that there’s a version issue as well: The app seems to require HA v0.95 or later, and unfortunately - AFAIK - legacy API key support was deprecated in v0.90. So, if you need the legacy API, you can’t have the new app,
Is there any way to re-install the old version?

It is possible to install an old version of HA.
https://www.home-assistant.io/docs/installation/updating/

For my issue, the notification is

Invalid config

The following components and platforms could not be set up:

cloud
mobile-app

My version is v0.102.2 and I commented the legacy configuration as you can see above.

#  auth_providers:
#   - type: homeassistant
#   - type: legacy_api_password
#     api_password: !secret http_password

with no success.
The problem is that it is NOT POSSIBLE to revert the iOS app

I restored my iOS device (iPod Touch) from a backup and was able to recover the old version of the iOS app that way.

Moved everything from ~/.homeassistant to ~/.homeassistant.backup
Restarted from fresh install, all files empty and configuration.yaml like this:

homeassistant:
  # Name of the location where Home Assistant is running
#  name: Home
  # Location required to calculate the time the sun rises and sets
#  latitude: 40.9083
#  longitude: -73.8346
  # Impacts weather/sunrise data (altitude above sea level in meters)
#  elevation: 44
  # metric for Metric, imperial for Imperial
#  unit_system: imperial
  # Pick yours from here: http://en.wikipedia.org/wiki/List_of_tz_database_time_zones
#  time_zone: America/New_York

# Example configuration.yaml entry
default_config:

http:
  # Uncomment this to add a password (recommended!)
  # api_password: PASSWORD
  # Uncomment this if you are using SSL or running in Docker etc
  # base_url: example.duckdns.org:8123

# Discover some devices automatically
discovery:

# Allows you to issue voice commands from the frontend in enabled browsers
conversation:

# Weather Prediction
sensor:
  platform: yr

# Text to speech
tts:
  - platform: google_translate
    service_name: google_say
    cache: false
    time_memory: 60

group: !include groups.yaml

And … it is not working, I’m desperated!
Same error in the log with default_config as recommended in the migration guide:

Invalid config
The following components and platforms could not be set up:

cloud
mobile-app
default-config
Please check your config.

As mentioned above, I was experiencing exactly the same issues as you detailed. I found this article late last night, tried it just now and perfect, all my default platforms and components load. I reinstalled the companion app and was able to set it up without incident. Hope it helps you. This article refers to beta testing, which I have not been involved with so just ignore that and follow the steps.
https://companion.home-assistant.io/en/next/troubleshooting/beta-cleaning

Hi Darren,

Thank you for the link but I did read that one as well 2 days ago.

The steps 1 to 9 are not relevant for me because I did a fresh installation, no integration, no entity prefixed by mobile_app, no .storage directory, no know_devices file, no nothing.
Steps 10 to 12 I already did but the mobile_app component is indeed missing from my HA configuration.

Why? Because it doesn’t start because cloud doesn’t start.
Why? This is where I am, not knowing why this damn cloud component is loading but doesn’t “setup” correctly even if there is nothing but “cloud:” in my configuration.yaml (or “default_config:” in my last attempt)

1 Like