Error returned from Supervisor: System is not ready with state: setup

This is my guess:

It’s just that by the time the shell is ready, the HA is not. So in the console it done waiting and said “not ready”.
By the time you type in banner, and hit the enter key in the same console, the HA is ready, so you have regular prompt.

@imola.zhp @jemn1 @chat - what’s your HW running HAOS, and roughly how long between your “not ready” and banner command?

1 Like

did you get this resolved?

Thank You! Typing ‘banner’ did not work the first time but it did the second time I tried :grinning:

TL:DR ‘supervisor repair’ worked for me just now

I had recently updated to Home Assistant OS 9.0 (Supervisor 08.6 and Core 2022.9.4)

For some reason my energy meter integration wasn’t working correctly afterwards. Given it connects via USB, I thought I’d reboot the VM (running on a Synology NAS). I watched it reboot and got the ‘system is not ready with state: setup’ error.

I was able to start core manually (core start), but the supervisor remained in a broken state.
‘supervisor reload’ returned ok, but running ‘supervisor info’ returned the same error.

So I tried ‘supervisor repair’, which took a while (and while it was doing so, I found this post), but it fixed everything, including my broken energy meter integration.


Did you ever run into an issue where everything you did gave you the ‘system is not ready with state: setup’ error? Mine is also set up in a Synology VM and every single command I try gives me that error, other than supervisor repair. The repair command doesn’t take too long and doing a reload just goes back to that error.

1 Like

I have had the same error on my HA running of Virtual Box hosted under MacOs on. a Mac Mini. This results i several possible layers contributing… If I follow the supervisor repair. then supervisor restart then banner and all appears well again… every every time. This essentially renders my installation unable to recover from power failures.


I also have HASS on an Synology-VM runnig for months, but now after a reboot of the NAS the VM stucks in “CLI not ready” => “login” and then “System not ready with state: Setup” => banner. Then the GUI starts as well and everything looks good.
Maybe a picky Timeout on a not-so-fast VM?

Maybe a connection to the Log:
2022-09-25 14:51:58.634 ERROR (MainThread) [homeassistant.components.hassio.handler] Timeout on /supervisor/options request

1 Like

I have that error with every reboot, HA i now simply a play toy with no reliability on my installation
I an continued at the LI with login. that does me no good with unattended operations

Has anyone managed to solve this issue when running in a VM (OSX)

Mine seem to be getting worse. Since i t was sort of working before the last couple of updates it is possible those can be involved. The general response seem to go by a Rasberry PI

I solved mine:
Make a full copy of the VM just in case, make a full backup from HAOS, spin up another VM from the latest HAOS image, making the VM settings the same, and then boot up, import from backup, and some final touch-ups.

In the end I have a new HAOS on the same IP. Zigbee stick passthrough to the new VM, and I don’t even have to re-pair anything.

And I spent maybe 30 minutes from start to finish… shorter than expected. So surprise in a good way.

This was new VM i did to try to over come all the errors i was getting including errors like this

I wil give your idea a run… after that time toe reformat the HD on the MA as these seem to be issues with disk integrity

I erased and reinstalled the whole thing on my mac mini. and now everything is running good again. PITA

This has started happening to me on qnap 251, using virtualixation station.
Has been fine for 2 years.
I even did a whole new install , but still wont start unless i type banner.
Would be good if it can get sorted.
Thankfully i found this thread.

Have u just ignored it for like 20 minutes?? I had found that it would sometimes start then and even when banner didnt run sometimes I would find the server had actually started and I could acces from external login.

No. I will try next time I start the VM.
It may well have been doing it for a while and I never noticed. But today I was messing with a integration and needed a quick restart.

This issue along the CLI not starting is a major PITA, I am still trying to recover from the refomat. The community I guess has never heard os STABLE version of a release

1 Like

Hi. Ok update, I just left it with the flashing cursor, didn’t type anything.
Home assistant started after about 10 mins, but the VM still shows the flashing cursor.
It’s probably been like this for a while and I’ve never noticed it.

But you can access Home Assistant through a browser right? I am also also a newbie but as far as I can figure it out there are several levels: The OS that The Virtual Machine operates o, the OS (In my case a generic linux). then the HA OS. Then the parts of HA like Docker. DO NOT THINK I KNOW WHAY I AM SAYING… Thats my just impression. There is probably HA before the cursor.

Errr. why is this flagged as the solution… A solution is in the post above this one :woozy_face: