Error returned from Supervisor: System is not ready with state: setup

Hi Everyone,

Today, after a server crash, I ran into my first big issue.

I did update the server to the latest versions yesterday, but that did not raise any issues to my knowledge.

After rebooting the host machine, I can ping HA Ip address, but cannot SSH to it, as the connection is refused.

As I’m running HA in a Hyper-V Virtual Machine, I can access the CLI and see that the server boots all the way to the command line with the error message below:

I tried searching this error, but couln’t find helpful results.

Does anyone know where I can find information to determine what to do next?

I do have backups so if worst comes to shove, I’ll do a full re-install but I’d like to give troubleshooting a shot if I can learn something out of it.

Cheers,

Check the logs.

1 Like

Well I’m still stuck.

I could even access Samba nor CLI so I finally resorted to restore a VM machine image that unfortunately is 4 months old.

Then I thought I could restore an automated backup that was uploaded on a cloud drive, but for some reason, when I restore it I get in the same issue and do not know how to approach or trouble shoot it.

I then thought that I could simply extract the yaml configuration files from the backups and restore manually all my configuration work but I found out the hard way that encrypted backups cannot be decrypted from any supported method. I did give a try to a python script someone wrote in 2019 to decrypt backups, but it failed.

Starting from the VM image I can upgrade HASS to the current versions, but I’ll have to painstakingly try to redo all the configurations work I’ve lost, and I suppose stay away from encrypted backups like the plague.

I also have a SSL issue that I’m not sure I understand where it comes from and need to try and fix. Basically I cannot use my duckdns address anymore and have to use the direct IP.

Hello
I was having a similar issue after a restart of my NAS on which I was running my HA in a VM.
I tried everything; even setting up a new VM with a blank installation.
I would get the exact same issue!

So randomly saw somewhere that when you get that error, its due to some timeout.
It said to wait a little while (few mins) then type “banner”

ha > banner

Then it should refresh and should work.
Really stupid, something has clearly happened in the recently updated because this has never occurred before. Not sure if running this in a VM is too niche for the developers to test this sort of thing.

3 Likes

Thanks, I will keep that in mind if I have the issue again and give it a try!

Miraculously I managed to restore my system, but I’m not sure how :slight_smile:

I was in the CLI trying commands to access the config files or the logs and just poking around basically.

And all of a sudden my instance was accessible again!!

I immediately made an unencrypted backup and updated eveything I could.

I’m up and running without a glitch since then to my great relief!

I am having the same issue but I am running on an RPi4. It randomly started working for you again, but what were some things that you have tried leading up to this?

Had the same issue and typed banner and bam, it worked! No idea why but thanks :slight_smile:

I type banner and it just returns the same error.

I got the same error on Pi3B.

Same problem here, with qcow2 image on Unraid 6.10.1. I can’t even find the way to show logs, So frustrating

I have the same question, with vmdk image on debian 11.4. A few days ago I had installed it in the docker, but it always cracked when I wanted to entered Addon Store.So I decided to use vmware to run the system, but it always shows this problem in the console.

I have already solve this problem now, you just need to update your system to version 8.3, then you can solve this problem. :wink: .

1 Like

But this is still the case after I upgraded to version 8.4

1 Like

I also have this error. Windows 11, Home Assistant v8.4, Virtualbox 6.1.30. Typing banner just produces the same error.

Am brand new to Home Assistant and it’s not going well so far. This is my third fresh install from the VDI disk image. Does anyone know how to even begin troubleshooting this?

I update 8.1 to 8.2,it also goes well

Try this:

ha >  supervisor repair

then

ha >  supervisor restart

and you should be able to visit the HA web page

Worked for me, thanks.