Error while loading page addon


I am running with homessistant 0.101.2 and 192 on a raspberry pi 3 (raspbian stretch) with docker and everytime I want to watch an addon from the Add-On Store I always get: “Error while loading page addon.”. The logs on the raspberry and from the docker container do not show any error, only when I click, e.g., on the “Configurator” add on it loads forever and just posts this error. Restarting the raspberry and homeassistant didn’t help. Also reinstalling hassio and clearing the browser cache did not help. Using Chromium did not work, either.

I checked the JS console in Firefox and got the following error:

Error loading page addon Error: "Loading chunk 5 failed.
(error: http://<hassio address>:8123/api/hassio/app/chunk.87d3a6d0178fb26762cf.js)"
    i Webpack
    value hass-router-page.ts:149

When watching the network analytics tab I can see, that chunk.87d3a6d0178fb26762cf.js has been loaded with http code 200, but it looks fairly incomplete (it ends with hassio-addon-logs {\n and the other chunk file end with a comment referring to a *.map file). Trying to load this file within another browser tab also loads just a part of the file and stops loading at the same position (still trying to fetch more). About 48.45KB has been loaded, it’s always the same.

I am running out of ideas what might be wrong. Do you guys know what I need to change?

I digged a little bit deeper and found the chunk.87d3a6d0178fb26762cf.js in the hassio supervisor container at /usr/src/hassio/hassio/api/panel. It’s saying its size is 55 KB, but other chunk*.js files are even bigger (e.g. chunk.9d7374dae6137783dda4.js has 88.1 KB) and are transmitted without problems. Any suggestions what’s going wrong?

currently i have similiar problem. I can not open any addon. When i click on any addon it throw error in console

Error loading page addon Error: "Loading chunk 11 failed.
(error: https:/<address>:8123/api/hassio/app/chunk.9d7374dae6137783dda4.js)"

when i request that url i get
502: Bad Gateway

1 Like

Same problem after updating to 0.105.2
When trying to open a add-on config page via the Hassio/Supervisor Dashboard.

Error loading page addon ChunkLoadError: Loading chunk 7 failed.
1 Like

I have same problem, but not only with addon. I see this error on regular pages, like Configuration, Developer tools, etc…and on Android device too. As described here too: JS chunks not loading with Docker Install

I am getting this same error, and it’s preventing me from loading the Integrations page, so I can no longer add new integrations! Has any figured this out? V0.114.1

Same issue here with several pages. Sometimes they and sometimes they don’t. I’m on a fresh install with version 0.114.3 and the system si running for only about 24hours :frowning:

For those, who google this error like me.

You probably use nginx proxy manager addon to encrypts your connection.
Try to repeat error while connect directly to home assistan. Like http://hassio.local:8123

If everything works fine - Reinstall NPM addon. I have no idea why, but it helps.
You may not be afraid of your addon’s data, they will save, if you uninstall addon and install it through supervisor

1 Like

Thank you for this. Had this issue with all my addons, after browsing locally to the ip. I was able to reinstall the addons and get them working.

I was still having this error after following all the suggested steps to no avail… Then I tried with Chrome instead of Opera and viola! I wasn’t getting the ‘Error while loading page’ error. THEN after restarting(and updating) my PC, it works with Opera. :man_shrugging: