ESP Home devices requesting 'Platform' Key

Just updated esphome and now I cant access the devices, error message:

INFO ESPHome 2024.6.1
INFO Reading configuration /config/esphome/cylinder-temp.yaml…
Failed config

ota.unknown: [source /config/esphome/cylinder-temp.yaml:27]

‘ota’ requires a ‘platform’ key but it was not specified.

Any idea how to add the required platform key to resolve my issue please

1 Like

It’s in the docs (the requirement has changed):

Because of this breaking change mentioned in the release notes:

Though the release notes do not make very clear what is needed. But the error does.

Many thanks for the swift replies, to experienced users the instructions are ‘noddy proof’, but after reading, for me the simplest is to flatten the ESP device and restart.

Here, read this in case it helps. Someone has already gone through the trouble of creating simple instructions and pinned the post so others would find it.

Thanks for your contribution @nickrout

4 Likes

Thanks for the info to the guide, it worked which is great, I was adding the platform detail before the password as per the ESP OTA config, but it didn’t like it, anyhoo it works now.

Thanks for you help, much appreciated.

The order shouldn’t matter.