ESP32 Camera

Hi, I flashed my ESPCam according to this : https://www.youtube.com/watch?v=-towjof_ixU Using ESPHome, the same board and even the same code.
I also tried every code I found at esphome site, but I can’t get it working.
I am able to add it in integration by adding 666.local for 6053 port, but I can’t see the image in integration as others do.

ESPHome log says:

Blockquote
INFO Reading configuration…
INFO Starting log output from 666.local using esphome API
INFO Connecting to 666.local:6053 (192.168.0.107)
INFO Successfully connected to 666.local
[20:21:21][I][application:097]: esphome-core version 1.12.2 compiled on Apr 24 2019, 19:01:57
[20:21:21][C][wifi:371]: WiFi:
[20:21:21][C][wifi:253]: SSID: [redacted]
[20:21:21][C][wifi:254]: IP Address: 192.168.0.107
[20:21:21][C][wifi:256]: BSSID: [redacted]
[20:21:21][C][wifi:257]: Hostname: ‘666’
[20:21:21][C][wifi:261]: Signal strength: -38 dB ▂▄▆█
[20:21:21][C][wifi:262]: Channel: 11
[20:21:21][C][wifi:263]: Subnet: 255.255.255.0
[20:21:21][C][wifi:264]: Gateway: 192.168.0.1
[20:21:21][C][wifi:265]: DNS1: 192.168.0.1
[20:21:21][C][wifi:266]: DNS2: 0.0.0.0
[20:21:21][C][logger:142]: Logger:
[20:21:21][C][logger:143]: Level: DEBUG
[20:21:21][C][logger:144]: Log Baud Rate: 115200
[20:21:21][C][logger:145]: Hardware UART: UART0
[20:21:21][C][esp32_camera:044]: ESP32 Camera:
[20:21:21][C][esp32_camera:045]: Name: bedroom
[20:21:21][C][esp32_camera:046]: Board Has PSRAM: YES
[20:21:21][C][esp32_camera:048]: Data Pins: D0:5 D1:18 D2:19 D3:21 D4:36 D5:39 D6:34 D7:35
[20:21:21][C][esp32_camera:049]: VSYNC Pin: 25
[20:21:21][C][esp32_camera:050]: HREF Pin: 23
[20:21:21][C][esp32_camera:051]: Pixel Clock Pin: 22
[20:21:21][C][esp32_camera:052]: External Clock: Pin:0 Frequency:20000000
[20:21:21][C][esp32_camera:053]: I2C Pins: SDA:26 SCL:27
[20:21:21][C][esp32_camera:054]: Reset Pin: -1
[20:21:21][C][esp32_camera:075]: Resolution: 640x480 (VGA)
[20:21:21][C][esp32_camera:098]: JPEG Quality: 10
[20:21:21][C][esp32_camera:100]: Contrast: 0
[20:21:21][C][esp32_camera:101]: Brightness: 0
[20:21:21][C][esp32_camera:102]: Saturation: 0
[20:21:21][C][esp32_camera:103]: Vertical Flip: ON
[20:21:21][C][esp32_camera:104]: Horizontal Mirror: ON
[20:21:21][C][esp32_camera:121]: Test Pattern: NO
[20:21:21][C][api:101]: API Server:
[20:21:21][C][api:102]: Address: 666.local:6053
[20:21:21][C][ota:127]: Over-The-Air Updates:
[20:21:21][C][ota:128]: Address: 666.local:3232
[20:21:29][D][esp32_camera:159]: Got Image: 0x3ffc7c78 len=16775 width=640 height=480 format=3

Can anyone help?

I assume you have clicked on the integration and configured it with the api password?

Now what entities do you see in ha in dev-state?

I did.
I see just the other entities, like switches, etc.

I’m having the same problem. Have you fixed this problem, and if so, how?

Post your esphome configuration yaml file, properly formatted, text not a picture.

Post your esphome log file (text not a picture).

Tell us what device you are using.

Post a picture of your relevant integrations panel.

Above all, read he posting rules How to help us help you - or How to ask a good question

I’m sorry. I forgot to add the esp32_camera component inside the configuration. That’s how I managed to add the esp camera to the integrations, but didn’t see any entities. With this yaml file everything works as expected:

esphome:
  name: espcam_voordeur
  platform: ESP32
  board: nodemcu-32s

wifi:
  ssid: "secret"
  password: "secret"

logger:

# Enable Home Assistant API
api:
  password: "secret"

ota:
  password: "secret"

esp32_camera:
  external_clock:
    pin: GPIO0
    frequency: 20MHz
  i2c_pins:
    sda: GPIO26
    scl: GPIO27
  data_pins: [GPIO5, GPIO18, GPIO19, GPIO21, GPIO36, GPIO39, GPIO34, GPIO35]
  vsync_pin: GPIO25
  href_pin: GPIO23
  pixel_clock_pin: GPIO22
  power_down_pin: GPIO32

  # Image settings
  name: espcam_voordeur
  max_framerate: 5 fps
  resolution: 640x480
  jpeg_quality: 10